Elasticsearch is not installed in my laptop

image

Hi @Talha_Naeem .

Try this:

.\bin\elasticsearch.bat

More info here.

Dear RabBtt_BR, I try it but it shows this error

Welcome to our community! :smiley:

Please don't post pictures of text, logs or code. They are difficult to read, impossible to search and replicate (if it's code), and some people may not be even able to see them :slight_smile:

Dear Mark Walkom, I post the picture because show the proper issue because sometimes text shows not proper problem.

Guys Can you please help me how to resolve this issue. Whenever I am running elasticseach.bat file in cmd I am getting below error. Needs your help I new to ELK stack.

D:\ELASTIC\elasticsearch-8.2.3\bin> .\elasticsearch.bat
'.COM;.EXE;.BAT;.CMD;.VBS;.JS;.WS;.MSC' is not recognized as an internal or external command,
operable program or batch file.

Isn't is just elasticsearch.bat?

Yes Bro, I have tried many ways but getting same error again and again.

What if you double click the bat via explorer?

(Also, I am not your bro.)

Getting this error after double clicking on .bat file.

image

And do you have the correct permissions?

I don't know about permissions.

Search for "windows cannot access the specified device path or file. you may not have appropriate permissions" and you will find some instructions on how to resolve it. If it works, you will probably be able to run the bat file.