Issue with server.publicBaseUrl

Hello,

I've deployed Kibana 7.14, behind a NGINX proxy, but keep getting a toast notification that server.publicBaseUrl has not been set; yet it has been in kibana.yml. Is there a way to dump the running configuration to ensure it has indeed been set? or is there something I need to do differently from an NGINX perspective please.

Thanks.

Is there a way to dump the running configuration to ensure it has indeed been set?

Unfortunately, no. It's not currently possible due to security reasons since the config file might contain sensitive settings.
Have you run Kibana with server.publicBaseUrl set in kibana.yml ? Or you adjusted the config while Kibana was running and sent the SIGHUP signal?

Hi @Mikhail_Shustov .. I am using the Kibana docker image and have checked that it has been set correctly in kibana.yml. The container has been restarted multiple times. Thanks.

Could you try to set server.publicBaseUrl value via an ENV var? It should be SERVER_PUBLICBASEURL: ... according to

Thank you, that appears to have resolved the issue :slight_smile: though doesn't explain why it's not being picked up from kibana.yml :frowning: