Issues with elastic 8.x yum repository

Hi, we've been experiencing issues with the elastic 8.x yum repository since this morning (UTC). The yum update command is failing with the following error

$ sudo yum -y update-minimal --security --skip-broken

Loaded plugins: extras_suggestions, langpacks, priorities, update-motd
amzn2-core                                                                                                                                                                                                                                                                                             | 3.6 kB  00:00:00
amzn2extra-docker                                                                                                                                                                                                                                                                                      | 2.9 kB  00:00:00
amzn2extra-epel                                                                                                                                                                                                                                                                                        | 3.0 kB  00:00:00
amzn2extra-kernel-5.10                                                                                                                                                                                                                                                                                 | 3.0 kB  00:00:00
amzn2extra-postgresql14                                                                                                                                                                                                                                                                                | 2.9 kB  00:00:00
amzn2extra-ruby3.0                                                                                                                                                                                                                                                                                     | 2.9 kB  00:00:00
datadog                                                                                                                                                                                                                                                                                                | 2.9 kB  00:00:00
datadog_v7                                                                                                                                                                                                                                                                                             | 2.9 kB  00:00:00
elastic-8.x                                                                                                                                                                                                                                                                                            | 1.3 kB  00:00:00
epel/x86_64/metalink                                                                                                                                                                                                                                                                                   |  26 kB  00:00:00
mysql56-community                                                                                                                                                                                                                                                                                      | 2.6 kB  00:00:00
rsyslog_v8                                                                                                                                                                                                                                                                                             | 3.0 kB  00:00:00
treasuredata                                                                                                                                                                                                                                                                                           | 3.0 kB  00:00:00


 One of the configured repositories failed (Unknown),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=<repoid> ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>
        or
            subscription-manager repos --disable=<repoid>

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Parsing primary.xml error: Start tag expected, '<' not found

The command works when I disable the elastic-8.x repo.

The content of the /etc/yum.repos.d/elastic-8.x.repo looks liks this

[elastic-8.x]
name=Yum Repository
baseurl=https://artifacts.elastic.co/packages/8.x/yum
enabled=1
fastestmirror_enabled=0
gpgcheck=1
gpgkey=https://artifacts.elastic.co/GPG-KEY-elasticsearch

I have tried to clean the yum cache via sudo yum clean all but that didn't help.

Something similar is happening with the logstash 8.x repo as well. Any idea what could be the problem?

Thanks!

1 Like

Hi, there.

We're having the same problem.
Had to stop using the elastic repo temporarily because it was messing up our automated deployments.
It also just started happening in the last few hours... It was working fine before.

EDIT: We're also using Amazon Linux 2, the same as @kunalyadav is using apparently. Not sure if the error is specific to that OS.

Thanks.

We ran into the same issue here. No idea why the yum repo started failing.

@kunalyadav what worked for me for the time being was direct downloading the rpm and installing it.

curl -L -O https://artifacts.elastic.co/downloads/beats/filebeat/filebeat-8.13.0-x86_64.rpm
sudo rpm -vi filebeat-8.13.0-x86_64.rpm

This isn't a scalable fix though, we typically install a clean Filebeat every time we spin up one of our EC2 instances and it would be better to use the yum repo.

@kunalyadav

we are getting very similar error and yum throws a fit when it incorrectly formatted primary.xml. It cannot install other packages that are not part of the repo because this repo has incorrectly formatted primary.xml

Not sure when elastic are going to fix it.

I've escalated this issue to Elastic cloud support.

Sorry for the issues with this.

A tooling change on our side caused the repository to become unreadable on some older operating systems. We're working on a fix.

2 Likes

Seems like this has been fixed. We are no longer experiencing any issues. Thanks @TimV and team!