Item url {{key}} error in time series visualization

Hi,

In time series visual builder I created a table with the first column displaying string values. The data for which comes from field name called 'cities'.

Next I modified the Item Url field under Panel Options to enter "https://www.google.com/". Now when I click on any of the strings in the first column it takes me to https://www.google.com/ as desired.

Next I tried to leverage the {{key}} mustache template and modified Item Url to replace the google link with "https://www.somesite.com/country=usa&place={{cities}}", where cities is the field name populating the first column. This does not work. I see an error which says - error: "cities" not defined in [object Object]

Any suggestions on what's wrong with my usage?
Using version 6.6.2

Thanks

Does https://www.somesite.com/country=usa&place={{key}} work? I tried something similar in 7.2. I think {{key}} in the instructions needs to be taken literally here. :slight_smile:

Using {{key}} in the instructions literally worked. :slight_smile:
Thanks for the help.

1 Like