Java 7 Usage Is Not Recommended


(Shay Banon) #1

Hi All,

You might have seen the previous thread, but I am sending a direct mail

in any case. Java 7 has just been released, but it is not recommended for
use with elasticsearch (lucene). More details here:
http://markmail.org/thread/kulrw4sm2nsshrta. Will update when it is.

-shay.banon


(Clinton Gormley) #2

Hiya

You might have seen the previous thread, but I am sending a direct

mail in any case. Java 7 has just been released, but it is not
recommended for use with elasticsearch (lucene). More details
here: http://markmail.org/thread/kulrw4sm2nsshrta. Will update when it
is.

And besides the loop bug in hotspot, I see this comment was made here:
http://www.lucidimagination.com/search/document/1a0d3986e48a9348/warning_index_corruption_and_crashes_in_apache_lucene_core_apache_solr_with_java_7

    In case you upgrade to Java 7, remember that you may have to
    reindex, as the unicode version shipped with Java 7 changed and
    tokenization behaves differently (e.g. lowercasing). For more
    information, read JRE_VERSION_MIGRATION.txt in your distribution
    package!

clint


(system) #3