java.lang.IllegalStateException: The index [[.kibana/t1LHjtFXSKWK9oD76iBYIQ]]

I am trying to install Elasticsearch on one of our servers. It was used for an upgrade test of ELK before. I now want to put a clean install ELK 7.3 on this server.

I deleted all the old ELK files. Or so i thought but now when I try and install Elasticsearch 7.3 i get this error
[2019-08-02T10:57:14,952][INFO ][o.e.x.m.p.l.CppLogMessageHandler] [SERVERNAME] [controller/8312] [Main.cc@110] controll
er (64 bit): Version 7.3.0 (Build ff2f774f78ce63) Copyright (c) 2019 Elasticsearch BV
[2019-08-02T10:57:15,624][ERROR][o.e.g.GatewayMetaState ] [SERVERNAME] failed to read or upgrade local state, exiting.
..
java.lang.IllegalStateException: The index [[.kibana/t1LHjtFXSKWK9oD76iBYIQ]] was created with version [5.6.13] but the
minimum compatible version is [6.0.0-beta1]. It should be re-indexed in Elasticsearch 6.x before upgrading to 7.3.0.
at org.elasticsearch.cluster.metadata.MetaDataIndexUpgradeService.checkSupportedVersion(MetaDataIndexUpgradeServ
ice.java:126) ~[elasticsearch-7.3.0.jar:7.3.0]

How do i delete the index. I cannot see it anywhere?

There's still old data referenced by the path.data setting in your elasticsearch.yml file. Point path.data at a new empty directory, or clear out whatever it's currently pointing to.

David, I tried putting new path in my elasticseach.YML file path.data: D:/ELKData and have tried path.data: D:\ELKData. and I still get the same error.

Elasticsearch is still finding some data in its data path. Either the new data path D:\ELKData isn't empty, or else you've not correctly set path.data to point to this new path. Perhaps you are editing a different elasticsearch.yml from the one that Elasticsearch is actually using for its config?