.keyword after every field


When i am creating any visualization, there the field is appearing as field.keyword

I just want the field name . How to do that.


Thanks in Advance.

The default Elasticsearch mapping for fields is a multi-mapping that is both text and keyword, and to differentiate these Elasticsearch adds .keyword. So one solution for you is to change your mappings in Elasticsearch and then re-index.

Another solution is to change the label for each visualization you create, in the "Advanced options" for the aggregation.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.