Kibana 4.3.1 On Windows XP - Unable to connect to Elasticsearch at http://localhost:9200


(Rajesh Swarnkar) #1

Hello there.
I am trying to setup elasticsearch-2.1.1 and kibana-4.3.1 on windows XP SP3:
I am able to push data to ES and able to access it via Head Plugin. But Kibana is not connecting to ES, it shows:
Status: Red
plugin:elasticsearch : Unable to connect to Elasticsearch at http://localhost:9200. Retrying in 2.5 seconds.

Changes made into elasticsearch.yml:
network.host: 127.0.0.1
http.port: 9200

Changes made to kibana.yml:
server.host: "127.0.0.1"
elasticsearch.url: "http://localhost:9200"
elasticsearch.ssl.verify: false

I even tried adding ports 9200 and 5601 to firewall exception but no luck. Please suggest.

Kibana Log:
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:kibana","info"],"pid":2624,"name":"plugin:kibana","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:elasticsearch","info"],"pid":2624,"name":"plugin:elasticsearch","state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["error","elasticsearch"],"pid":2624,"message":"Request error, retrying -- connect UNKNOWN"}
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:kbn_vislib_vis_types","info"],"pid":2624,"name":"plugin:kbn_vislib_vis_types","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["warning","elasticsearch"],"pid":2624,"message":"Unable to revive connection: http://localhost:9200/"}
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["warning","elasticsearch"],"pid":2624,"message":"No living connections"}
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:elasticsearch","error"],"pid":2624,"name":"plugin:elasticsearch","state":"red","message":"Status changed from yellow to red - Unable to connect to Elasticsearch at http://localhost:9200. Retrying in 2.5 seconds.","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:markdown_vis","info"],"pid":2624,"name":"plugin:markdown_vis","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:metric_vis","info"],"pid":2624,"name":"plugin:metric_vis","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:spyModes","info"],"pid":2624,"name":"plugin:spyModes","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:statusPage","info"],"pid":2624,"name":"plugin:statusPage","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["status","plugin:table_vis","info"],"pid":2624,"name":"plugin:table_vis","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2015-12-27T09:44:26+00:00","tags":["listening","info"],"pid":2624,"message":"Server running at http://127.0.0.1:5601"}
{"type":"log","@timestamp":"2015-12-27T09:44:29+00:00","tags":["warning","elasticsearch"],"pid":2624,"message":"Unable to revive connection: http://localhost:9200/"}
{"type":"log","@timestamp":"2015-12-27T09:44:29+00:00","tags":["warning","elasticsearch"],"pid":2624,"message":"No living connections"}
..
{"type":"response","@timestamp":"2015-12-27T09:45:43+00:00","tags":[],"pid":2624,"method":"get","statusCode":200,"req":{"url":"/","method":"get","headers":{"host":"localhost:5601","user-agent":"Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0","accept":"text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8","accept-language":"en-US,en;q=0.5","accept-encoding":"gzip, deflate","connection":"keep-alive"},"remoteAddress":"127.0.0.1","userAgent":"127.0.0.1"},"res":{"statusCode":200,"responseTime":78,"contentLength":9},"message":"GET / 200 78ms - 9.0B"}
{"type":"log","@timestamp":"2015-12-27T09:45:44+00:00","tags":["warning","elasticsearch"],"pid":2624,"message":"Unable to revive connection: http://localhost:9200/"}
{"type":"log","@timestamp":"2015-12-27T09:45:44+00:00","tags":["warning","elasticsearch"],"pid":2624,"message":"No living connections"}


(Mark Walkom) #2

What does ping localhost return?


(Rajesh Swarnkar) #3

Here is the output:

C:\Documents and Settings\Swarnkar>ping localhost

Pinging swarnkarr [127.0.0.1] with 32 bytes of data:

Reply from 127.0.0.1: bytes=32 time<1ms TTL=64
Reply from 127.0.0.1: bytes=32 time<1ms TTL=64
Reply from 127.0.0.1: bytes=32 time<1ms TTL=64
Reply from 127.0.0.1: bytes=32 time<1ms TTL=64

Ping statistics for 127.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

Here swarnkarr is user domain.

Also, I see this when I start kibana.bat

'WHERE' is not recognized as an internal or external command, operable program or batch file.

I tried Commenting bat lines containing WHERE as @KavyaS says here.
No luck.


Kibana showing 'WHERE' is not an int or ext command on start up
(Mark Van Der Harst) #4

Hi,

You should bind Elasticsearch to localhost in stead of the ip 127.0.0.1.

Changes made into elasticsearch.yml:
network.host: localhost
http.port: 9200

Changes made to kibana.yml:
elasticsearch.url: "http://localhost:9200"
elasticsearch.ssl.verify: false

Don't use server.host parameter in kibana.yml


#5

System: Windows 8.1
Kibana:4.6.3
Elasticsearch:2.4.1

It's a pity that,on my computer,this method doesn't work.

It's strange:
When I unplug the network cable(and restart Kibana),the error occurs.
When I plug in the network cable,the error disappears,and everything runs well.

I haven't changed any setting in kibana.yml.
And I haven't set "network.host" or "http.port" in elasticsearch.yml.

Is it possible to use Kibana without the network cable?

Thank you in advance.


(system) #6