Kibana 4.3 showing blank pages after creating or deleting Indices


(Vikas Gopal) #1

Hi Experts,

Sorry to ask this again but I am not able to get anything on my kibana pages after creating or deleting index in ES2.1.0 . I have just downloaded a fresh Kibana 4.3 with ES2.1.0. Initially when there no index kibana web page is showing setting page where we can create Index pattern. But when I am creating or deleting any index in ES kibana stops showing pages .

Already Opened issues


My ES logs are full with the following errors. I have one more additional error which I mentioned in the 36023/6 discussion.

[2015-12-04 08:24:35,155][WARN ][index.translog           ] [Bast] [my_index][0]
 failed to delete temp file E:\ELK_Traning\latest\elasticsearch-2.1.0\data\elast
icsearch\nodes\0\indices\my_index\0\translog\translog-8662523151377925346.tlog
java.nio.file.NoSuchFileException: E:\ELK_Traning\latest\elasticsearch-2.1.0\dat
a\elasticsearch\nodes\0\indices\my_index\0\translog\translog-8662523151377925346
.tlog
at sun.nio.fs.WindowsException.translateToIOException(WindowsException.j
ava:79)
at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.jav
a:97)
at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.jav
a:102)
at sun.nio.fs.WindowsFileSystemProvider.implDelete(WindowsFileSystemProv
ider.java:269)

Newbie Question - Settings Page Blank
(Vikas Gopal) #2

Here are my specifications , in case some one wants to reproduce the above issue

OS :- Windows 8 enterprise
ES 2.1.0
Kibana 4.3.0
jdk1.8.0_65

I am just creating an index in ES as follows

PUT my_index
{
"mappings": {
"my_type": {
"properties": {
"date": {
"type": "date",
"format": "yyy-MM-dd HH:mm:ss||yyyy-MM-dd||epoch_millis"
}
}
}
}
}
PUT my_index/my_type/1
{ "date": "2015-01-01" }
PUT my_index/my_type/3
{ "date": 1420070400001 }


(Tanya Bragin) #3

Is this a fresh install of both Kibana and Elasticsearch? Error in Elasticsearch seems to indicate there is some sort of corruption going on at that level.


(Vikas Gopal) #4

Hi Tanya,

Yes it is all fresh Installation . I am sure it is not just me facing this problem . I have seen many new posts from different users facing same issue . Earlier I was thinking may be windows 8 causes the problem , but Ubuntu users also facing the same issue .

Things I have done

  1. Fresh Installation of ES and Kibana
  2. No change in the configurations .So I am using all the default config settings for both ES and Kibana.
  3. Create a simple index using Sense as shown above.

Problem I am facing
When I type Index name in kibana , I can see "date" field appears for selection . When I click on date field , kibana keep on processing and keep on trying to get data in the discover page . After 10-15 min sometimes I get Fatal error on kibana page (mentioned in my original post) otherwise I kill processes of ES and Kibana and start both the processes again , to check if the index pattern has been created in kibana , unfortunately every time after doing all the above steps Kibana shows blank pages .

My Understanding

As per my understanding it is the date which creates the problem , the index which I am creating directly in ES using Sense is not correct or new ES is not supporting it .


Deleted an index in Kibana Settings, and now all Kibana screens are blank
(Tanya Bragin) #5

Seems difficult to introduce. As you point out, problem seems to be environment-specific. It might help if you posted more details about what type of data you're storing in ES, what type of indices you're creating and deleting, etc..

Do you get this problem repeatedly or only in certain situations? For instance, if you create indices based on the Kibana getting started tutorial and then delete them, do you get the blank screen? https://www.elastic.co/guide/en/kibana/current/getting-started.html


(Vikas Gopal) #6

Tanya , as I said it is a fresh installation and i do not have any Index in ES . Since it is a new release so I just want to have hands on it. I have created a very basic index in ES2.1 using SENSE shown below.The situation is I can only see a blank page in kibana I have deleted all the indexes except .kibana .I cleared cache , restart ES and kibana.

Do you think problem is with my Index ?

PUT my_index
{
"mappings": {
"my_type": {
"properties": {
"date": {
"type": "date",
"format": "yyy-MM-dd HH:mm:ss||yyyy-MM-dd||epoch_millis"
}
}
}
}
}


PUT my_index/my_type/1
{ "date": "2015-01-01" } 
PUT my_index/my_type/3
{ "date": 1420070400001 }

(Vikas Gopal) #7

I was exited that kibana 4.3 is here so we will have some exiting stuff but unfortunately I am not able to create Index pattern, so stuck on first step only, so no point to check latest features Kibana introduced.It seems nobody has tried things on latest relies that is ES2.1 and kibana 4.3 . Anyways I am hoping someone can reproduce or understand my problem till than I am using the older version of ES1.7.3 and Kibana 4.1.2.


(Vikas Gopal) #8

Here i saw one more user reporting this problem in kibana 4.2. I bet it was not cache issue as I deleted or clear my cache still same situation .


(Lovika Jain) #12

Hi Vikas,

Even I am facing the same issue. I just installed fresh ES 2.1.0 and Kibana 4.3.0 and when ever I am trying URL : http://hostname:5601/ it is showing the blank page.
I tried to reinstall the ES and kibana twice and thrice.


(Vikas Gopal) #13

Hi Lovika,

For me it was an environment issue , I was on windows 8, 32 bit version which causes the problem. It has not been mentioned anywhere that kibana misbehaves with windows 8. But some how I got to know and i shifted to windows 7 or Unix flavor , and it works for me.Which OS you are on ?

Regards
VG


(Lovika Jain) #14

I am working on linux. I didn't get any errors in logs still i am facing this issue.
can you check my config files? if i have missed anything in it?


(Vikas Gopal) #15

yes I can check your config files, but I also saw some Unix users reporting same problem .Anyways I was on Ubuntu 14.4 amd 64 server.


(Lovika Jain) #16

Kibana.yml
# Kibana is served by a back end server. This controls which port to use.
server.port: 5601

# The host to bind the server to.
  server.host: "10.155.153.74"

# A value to use as a XSRF token. This token is sent back to the server on each request
# and required if you want to execute requests from other clients (like curl).
# server.xsrf.token: ""

# If you are running kibana behind a proxy, and want to mount it at a path,
# specify that path here. The basePath can't end in a slash.
# server.basePath: ""

# The Elasticsearch instance to use for all your queries.
  elasticsearch.url: "http://host:9200/"

# preserve_elasticsearch_host true will send the hostname specified in `elasticsearch`. If you set it to false,
# then the host you use to connect to *this* Kibana instance will be sent.
  elasticsearch.preserveHost: true

# Kibana uses an index in Elasticsearch to store saved searches, visualizations
# and dashboards. It will create a new index if it doesn't already exist.
  kibana.index: ".kibana"

# The default application to load.
  kibana.defaultAppId: "discover"

# If your Elasticsearch is protected with basic auth, these are the user credentials
# used by the Kibana server to perform maintenance on the kibana_index at startup. Your Kibana
# users will still need to authenticate with Elasticsearch (which is proxied through
# the Kibana server)
# elasticsearch.username: "user"
# elasticsearch.password: "pass"

# SSL for outgoing requests from the Kibana Server to the browser (PEM formatted)
# server.ssl.cert: /path/to/your/server.crt
# server.ssl.key: /path/to/your/server.key

# Optional setting to validate that your Elasticsearch backend uses the same key files (PEM formatted)
# elasticsearch.ssl.cert: /path/to/your/client.crt
# elasticsearch.ssl.key: /path/to/your/client.key

Elasticsearch.yml
# ---------------------------------- Cluster -----------------------------------
#
# Use a descriptive name for your cluster:
#
cluster.name: elasticsearch
#
# ------------------------------------ Node ------------------------------------
#
# Use a descriptive name for the node:
#
node.name: Node
node.master: true
node.data: true
#
# Add custom attributes to the node:
#
# node.rack: r1
#
# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comma):
#
# path.data: /path/to/data
#
# Path to log files:
#
# path.logs: /path/to/logs
#
# ----------------------------------- Memory -----------------------------------
#
#
# Lock the memory on startup:
#
bootstrap.mlockall: true
# index.number_of_shards: 2
# index.number_of_replicas: 1
#
# Make sure that the ES_HEAP_SIZE environment variable is set to about half the memory
# available on the system and that the owner of the process is allowed to use this limit.
#
# Elasticsearch performs poorly when the system is swapping the memory.
#
# ---------------------------------- Network -----------------------------------
#
# Set the bind address to a specific IP (IPv4 or IPv6):
#
network.host: 10.155.153.74
network.publish_host: 10.155.153.74
network.bind_host: 10.155.153.74

        #
        # Set a custom port for HTTP:
        #
          http.port: 9200
        #
        # For more information, see the documentation at:
        # <http://www.elastic.co/guide/en/elasticsearch/reference/current/modules-network.html>

I created one kibana.service file too
[Unit]
Description=Kibana 4 Web Interface
After=elasticsearch.service
After=logstash.service
[Service]
ExecStartPre=rm -rf /var/run/kibana.pid
ExecStart=/opt/kibana4/bin/kibana/
ExecReload=kill -9 $(cat /var/run/kibana.pid) && rm -rf /var/run/kibana.pid && /opt/kibana4/bin/kibana/
ExecStop=kill -9 $(cat /var/run/kibana.pid)
[Install]
WantedBy=multi-user.target

Please let me know if i have missed something or made any error anywhere while configuring!

Thanks,
Lovika


(Vikas Gopal) #17

Hmmm, I do not see any problem in the config file .


(Lovika Jain) #18

thanks I got the issue resolved , Able to access kibana URL from the server machine but not from other machine some access permission issue is there . Thanks :slight_smile:


(Vikas Gopal) #19

Great , yeah that may be the angle .I mean access issue .


#20

I am using windows 8.1 and had a blank initial page on kibana (could see navigation menu but not page) after installation. I made sure that the properties of the kibana root folder were not set to read-only in the properties and made sure that the IIS user account had access on the web.config.

Probably worth check IIS user security on other folders too (I did a full control on the whole kibana folder just cos I'm testing it out for now, but that's definitely not a recommended fix for any development projects and certainly not for production!)


(Ravi Shanker Reddy) #21

I am also facing this issue now with 5.0 kibana. I deleted one indices in the kibana after that every page is blank. I tried re-installing and everything but nothing wirks.


(Ray Li) #22

is your issue resovled?


(Ravi Shanker Reddy) #23

No I changed my ES server and copied all the ES data to this server.