Problem in Kibana 4.2.1


(Vikas Gopal) #1

Hi Experts,

I have seen many folks asking the same question but nowhere we found the solution . I have recently downloaded Kibana 4.2.1 along with ES 2.1.0 . I do not have any index so just tried to check the look and feel of Kibana . Now after hitting localhost:5601 I can only see a blank screen/page . I tried to navigate to the settings tab but nothing happened.

Solution I tried to implement
I was following After installation on Kibana 4.2.0 the page is blank #12 and here they recommended that issue has been fixed and 3 files have been modified .
saved_object.js
file_upload.js
_objects.js

So I changed above 3 files from here.Still situation is same.

Please suggest what needs to be done here as Kibana is not working as the way it was working in the older versions.


ES 2.1.0 error
Kibana 4.3 showing blank pages after creating or deleting Indices
(Vikas Gopal) #2

Even I tried creating an index . So in ES 2.1.0 I have created an index and I can see 2 indexes in sense

GET /_cat/indices/?v
health status index   pri rep docs.count docs.deleted store.size pri.store.size 
yellow open   .kibana   1   1          4            0     12.2kb         12.2kb 
yellow open   corr_te   5   1        100            0    654.5kb        654.5kb 

Still Kibana screen is blank .I can only see all the blank tabs i.e Discover , Settings etc


(David Pilato) #3

I don't think Kibana 4.2.1 is compatible with Elasticsearch 2.1.0. I think you should upgrade to Kibana 4.3


(Vikas Gopal) #4

I did the same so I tested it with kibana 4.3 still same situation . Now when I put new index name in the search to create index Kibana is keep on searching for 5 min and then throws an error

 Fatal Error
Courier Fetch Error: unhandled error Error: unknown error

at respond (http://localhost:5601/bundles/kibana.bundle.js:76162:16)
at checkRespForFailure (http://localhost:5601/bundles/kibana.bundle.js:76123:8)
at http://localhost:5601/bundles/kibana.bundle.js:74741:8
at processQueue (http://localhost:5601/bundles/commons.bundle.js:42339:29)
at http://localhost:5601/bundles/commons.bundle.js:42355:28
at Scope.$eval (http://localhost:5601/bundles/commons.bundle.js:43583:29)
at Scope.$digest (http://localhost:5601/bundles/commons.bundle.js:43394:32)
at Scope.$apply (http://localhost:5601/bundles/commons.bundle.js:43691:25)
at done (http://localhost:5601/bundles/commons.bundle.js:38140:48)
at completeRequest (http://localhost:5601/bundles/commons.bundle.js:38338:8)


(neal) #5

Hi vikas_gopal ! any progress? i have the same problem! thanks


(Vikas Gopal) #6

Hi @aqiao ,

The problem was with the environment, I mean I was facing this issue on Windows 8 32 bit V2.0 .
I moved this stack to 64 bit Windows server 2012 R2 standard and things working smoothly . So my recommendation would be change your OS . I guess the main problem is with 32 bit version .

Thanks
VG


(neal) #7

thanks vikas_gopal ! in my case, it's due to ES cluster server disk space is not enough


(system) #8