Kibana 4 behind reverse proxy. Is it possible?


(Konstantin Erman) #1

We currently use Kibana 3 hosted in IIS behind IIS reverse proxy for auhentication. Naturally we look at Kibana 4 Beta 3 expecting it to replace Kibana 3 soon. Kibana 4 is self hosted and works nicely when accessed directly, but we need authentication and whatever I do I cannot make it work from behind reverse proxy! Early or later I get 401 accessing some internal resource.

Wonder if anybody hit similar problem and have any insight how to make it work.
We cannot use Shield as its price is way beyond our bounds.

Thanks!
Konstantin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/18a667e4-21d5-45e6-abbb-836754796ea3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Cijo Thomas) #2

Its possible to use IIS with the following steps.

  1. Disable Output cache for the website you are using as reverse proxy.
  2. Run the website in a new apppool, which do not have any managed code.

With the above two steps, kibana4 runs fine with IIS as reverse proxy.

On Saturday, December 27, 2014 at 4:19:31 PM UTC-8, Konstantin Erman wrote:

We currently use Kibana 3 hosted in IIS behind IIS reverse proxy for
auhentication. Naturally we look at Kibana 4 Beta 3 expecting it to replace
Kibana 3 soon. Kibana 4 is self hosted and works nicely when accessed
directly, but we need authentication and whatever I do I cannot make it
work from behind reverse proxy! Early or later I get 401 accessing some
internal resource.

Wonder if anybody hit similar problem and have any insight how to make it
work.
We cannot use Shield as its price is way beyond our bounds.

Thanks!
Konstantin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7355f0ec-1bac-4e62-b675-a5f23d04ef7a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Konstantin Erman) #3

Thank you for the good news! I'm a little swamped currently, but I will
definitely give it a try when I get a minute.

Just to make sure - "disable Output cache for the website" - where is it in
IIS Management Console?

On Wednesday, January 28, 2015 at 4:38:01 PM UTC-8, Cijo Thomas wrote:

Its possible to use IIS with the following steps.

  1. Disable Output cache for the website you are using as reverse proxy.
  2. Run the website in a new apppool, which do not have any managed code.

With the above two steps, kibana4 runs fine with IIS as reverse proxy.

On Saturday, December 27, 2014 at 4:19:31 PM UTC-8, Konstantin Erman wrote:

We currently use Kibana 3 hosted in IIS behind IIS reverse proxy for
auhentication. Naturally we look at Kibana 4 Beta 3 expecting it to replace
Kibana 3 soon. Kibana 4 is self hosted and works nicely when accessed
directly, but we need authentication and whatever I do I cannot make it
work from behind reverse proxy! Early or later I get 401 accessing some
internal resource.

Wonder if anybody hit similar problem and have any insight how to make it
work.
We cannot use Shield as its price is way beyond our bounds.

Thanks!
Konstantin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d089ed71-71c4-4997-93fa-2dc7125b7f49%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Cijo Thomas) #4

I have been fighting with this for quite some time, Finally found the
workaround. Let me know if it helps you!

On Thu, Jan 29, 2015 at 10:12 AM, Konstantin Erman konste@gmail.com wrote:

Thank you for the good news! I'm a little swamped currently, but I will
definitely give it a try when I get a minute.

Just to make sure - "disable Output cache for the website" - where is it
in IIS Management Console?

On Wednesday, January 28, 2015 at 4:38:01 PM UTC-8, Cijo Thomas wrote:

Its possible to use IIS with the following steps.

  1. Disable Output cache for the website you are using as reverse proxy.
  2. Run the website in a new apppool, which do not have any managed code.

With the above two steps, kibana4 runs fine with IIS as reverse proxy.

On Saturday, December 27, 2014 at 4:19:31 PM UTC-8, Konstantin Erman
wrote:

We currently use Kibana 3 hosted in IIS behind IIS reverse proxy for
auhentication. Naturally we look at Kibana 4 Beta 3 expecting it to replace
Kibana 3 soon. Kibana 4 is self hosted and works nicely when accessed
directly, but we need authentication and whatever I do I cannot make it
work from behind reverse proxy! Early or later I get 401 accessing some
internal resource.

Wonder if anybody hit similar problem and have any insight how to make
it work.
We cannot use Shield as its price is way beyond our bounds.

Thanks!
Konstantin

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/r_uDcHR-rrw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d089ed71-71c4-4997-93fa-2dc7125b7f49%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/d089ed71-71c4-4997-93fa-2dc7125b7f49%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Warm Regards,
Cijo Thomas
+1 3125606441 <#SafeHtmlFilter_>

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAH6LTpEkRjF1kDbKEm5Frvwb6BBCH_Xhvm1hhKtMYtYCphrraQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Konstantin Erman) #5

Unfortunately I could not replicate your success :frowning:

Let me show you what I did in case you may be notice any difference from
your case.

https://lh6.googleusercontent.com/-HzQRKhGl9ag/VMqfkWnSF8I/AAAAAAAAAh0/SsXrJlQ2vW8/s1600/Output_Caching.png

https://lh6.googleusercontent.com/-V2VTx-iT888/VMqf0K7jChI/AAAAAAAAAh8/qC7umA0XP_U/s1600/AppPool1.png

https://lh6.googleusercontent.com/-4jL3Hyoq0QY/VMqgF7d0-II/AAAAAAAAAiE/77VOeAZP2e0/s1600/AppPool2.png

https://lh5.googleusercontent.com/-aBFCh_BZKn4/VMqgnM9ejhI/AAAAAAAAAiM/zxnsdD-VK8U/s1600/Error.png
Any ideas what I may be missing?

Thanks!
Konstantin

On Thursday, January 29, 2015 at 10:13:40 AM UTC-8, Cijo Thomas wrote:

I have been fighting with this for quite some time, Finally found the
workaround. Let me know if it helps you!

On Thu, Jan 29, 2015 at 10:12 AM, Konstantin Erman <kon...@gmail.com
<javascript:>> wrote:

Thank you for the good news! I'm a little swamped currently, but I will
definitely give it a try when I get a minute.

Just to make sure - "disable Output cache for the website" - where is it
in IIS Management Console?

On Wednesday, January 28, 2015 at 4:38:01 PM UTC-8, Cijo Thomas wrote:

Its possible to use IIS with the following steps.

  1. Disable Output cache for the website you are using as reverse proxy.
  2. Run the website in a new apppool, which do not have any managed code.

With the above two steps, kibana4 runs fine with IIS as reverse proxy.

On Saturday, December 27, 2014 at 4:19:31 PM UTC-8, Konstantin Erman
wrote:

We currently use Kibana 3 hosted in IIS behind IIS reverse proxy for
auhentication. Naturally we look at Kibana 4 Beta 3 expecting it to replace
Kibana 3 soon. Kibana 4 is self hosted and works nicely when accessed
directly, but we need authentication and whatever I do I cannot make it
work from behind reverse proxy! Early or later I get 401 accessing some
internal resource.

Wonder if anybody hit similar problem and have any insight how to make
it work.
We cannot use Shield as its price is way beyond our bounds.

Thanks!
Konstantin

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/r_uDcHR-rrw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d089ed71-71c4-4997-93fa-2dc7125b7f49%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/d089ed71-71c4-4997-93fa-2dc7125b7f49%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Warm Regards,
Cijo Thomas
+1 3125606441
<#CAH6LTpEkRjF1kDbKEm5Frvwb6BBCH_Xhvm1hhKtMYtYCphrraQ@mail.gmail.com_SafeHtmlFilter_>

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/cbf5e8d0-6769-4ef5-b625-9a6457fac86c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Cijo Thomas) #6

Can you show your URL rewrite rules ? Also are you using Kibana 4 beta 3 ?

On Thu, Jan 29, 2015 at 1:09 PM, Konstantin Erman konste@gmail.com wrote:

Unfortunately I could not replicate your success :frowning:

Let me show you what I did in case you may be notice any difference from
your case.

https://lh6.googleusercontent.com/-HzQRKhGl9ag/VMqfkWnSF8I/AAAAAAAAAh0/SsXrJlQ2vW8/s1600/Output_Caching.png

https://lh6.googleusercontent.com/-V2VTx-iT888/VMqf0K7jChI/AAAAAAAAAh8/qC7umA0XP_U/s1600/AppPool1.png

https://lh6.googleusercontent.com/-4jL3Hyoq0QY/VMqgF7d0-II/AAAAAAAAAiE/77VOeAZP2e0/s1600/AppPool2.png

https://lh5.googleusercontent.com/-aBFCh_BZKn4/VMqgnM9ejhI/AAAAAAAAAiM/zxnsdD-VK8U/s1600/Error.png
Any ideas what I may be missing?

Thanks!
Konstantin

On Thursday, January 29, 2015 at 10:13:40 AM UTC-8, Cijo Thomas wrote:

I have been fighting with this for quite some time, Finally found the
workaround. Let me know if it helps you!

On Thu, Jan 29, 2015 at 10:12 AM, Konstantin Erman kon...@gmail.com
wrote:

Thank you for the good news! I'm a little swamped currently, but I will
definitely give it a try when I get a minute.

Just to make sure - "disable Output cache for the website" - where is it
in IIS Management Console?

On Wednesday, January 28, 2015 at 4:38:01 PM UTC-8, Cijo Thomas wrote:

Its possible to use IIS with the following steps.

  1. Disable Output cache for the website you are using as reverse proxy.
  2. Run the website in a new apppool, which do not have any managed code.

With the above two steps, kibana4 runs fine with IIS as reverse proxy.

On Saturday, December 27, 2014 at 4:19:31 PM UTC-8, Konstantin Erman
wrote:

We currently use Kibana 3 hosted in IIS behind IIS reverse proxy for
auhentication. Naturally we look at Kibana 4 Beta 3 expecting it to replace
Kibana 3 soon. Kibana 4 is self hosted and works nicely when accessed
directly, but we need authentication and whatever I do I cannot make it
work from behind reverse proxy! Early or later I get 401 accessing some
internal resource.

Wonder if anybody hit similar problem and have any insight how to make
it work.
We cannot use Shield as its price is way beyond our bounds.

Thanks!
Konstantin

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/r_uDcHR-rrw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/d089ed71-71c4-4997-93fa-2dc7125b7f49%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/d089ed71-71c4-4997-93fa-2dc7125b7f49%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Warm Regards,
Cijo Thomas
+1 3125606441
<#14b3786b590d6772_CAH6LTpEkRjF1kDbKEm5Frvwb6BBCH_Xhvm1hhKtMYtYCphrraQ@mail.gmail.com_SafeHtmlFilter_>

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/r_uDcHR-rrw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/cbf5e8d0-6769-4ef5-b625-9a6457fac86c%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/cbf5e8d0-6769-4ef5-b625-9a6457fac86c%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Warm Regards,
Cijo Thomas
+1 3125606441 <#SafeHtmlFilter_>

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAH6LTpE1RoLVPN1aQWeJm-6nyWiovzr%3DhGudAmUeAGGgBAuYWg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Konstantin Erman) #7

Yes, Kibana 4 beta 3. And I have just one URL rewrite rule (pictured).
Were you getting the same error when it was not working for you?

https://lh3.googleusercontent.com/-oDiu_ncjJlA/VMrEJL-Qj_I/AAAAAAAAAic/so2IvrgTQbY/s1600/RewriteRule.png

On Thursday, January 29, 2015 at 3:31:56 PM UTC-8, Cijo Thomas wrote:

Can you show your URL rewrite rules ? Also are you using Kibana 4 beta 3 ?

On Thu, Jan 29, 2015 at 1:09 PM, Konstantin Erman <kon...@gmail.com
<javascript:>> wrote:

Unfortunately I could not replicate your success :frowning:

Let me show you what I did in case you may be notice any difference from
your case.

https://lh6.googleusercontent.com/-HzQRKhGl9ag/VMqfkWnSF8I/AAAAAAAAAh0/SsXrJlQ2vW8/s1600/Output_Caching.png

https://lh6.googleusercontent.com/-V2VTx-iT888/VMqf0K7jChI/AAAAAAAAAh8/qC7umA0XP_U/s1600/AppPool1.png

https://lh6.googleusercontent.com/-4jL3Hyoq0QY/VMqgF7d0-II/AAAAAAAAAiE/77VOeAZP2e0/s1600/AppPool2.png

https://lh5.googleusercontent.com/-aBFCh_BZKn4/VMqgnM9ejhI/AAAAAAAAAiM/zxnsdD-VK8U/s1600/Error.png
Any ideas what I may be missing?

Thanks!
Konstantin

On Thursday, January 29, 2015 at 10:13:40 AM UTC-8, Cijo Thomas wrote:

I have been fighting with this for quite some time, Finally found the
workaround. Let me know if it helps you!

On Thu, Jan 29, 2015 at 10:12 AM, Konstantin Erman kon...@gmail.com
wrote:

Thank you for the good news! I'm a little swamped currently, but I will
definitely give it a try when I get a minute.

Just to make sure - "disable Output cache for the website" - where is
it in IIS Management Console?

On Wednesday, January 28, 2015 at 4:38:01 PM UTC-8, Cijo Thomas wrote:

Its possible to use IIS with the following steps.

  1. Disable Output cache for the website you are using as reverse proxy.
  2. Run the website in a new apppool, which do not have any managed
    code.

With the above two steps, kibana4 runs fine with IIS as reverse proxy.

On Saturday, December 27, 2014 at 4:19:31 PM UTC-8, Konstantin Erman
wrote:

We currently use Kibana 3 hosted in IIS behind IIS reverse proxy for
auhentication. Naturally we look at Kibana 4 Beta 3 expecting it to replace
Kibana 3 soon. Kibana 4 is self hosted and works nicely when accessed
directly, but we need authentication and whatever I do I cannot make it
work from behind reverse proxy! Early or later I get 401 accessing some
internal resource.

Wonder if anybody hit similar problem and have any insight how to
make it work.
We cannot use Shield as its price is way beyond our bounds.

Thanks!
Konstantin

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/r_uDcHR-rrw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/d089ed71-71c4-4997-93fa-2dc7125b7f49%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/d089ed71-71c4-4997-93fa-2dc7125b7f49%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Warm Regards,
Cijo Thomas
+1 3125606441
<#CAH6LTpE1RoLVPN1aQWeJm-6nyWiovzr=hGudAmUeAGGgBAuYWg@mail.gmail.com_14b3786b590d6772_CAH6LTpEkRjF1kDbKEm5Frvwb6BBCH_Xhvm1hhKtMYtYCphrraQ@mail.gmail.com_SafeHtmlFilter_>

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/r_uDcHR-rrw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/cbf5e8d0-6769-4ef5-b625-9a6457fac86c%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/cbf5e8d0-6769-4ef5-b625-9a6457fac86c%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Warm Regards,
Cijo Thomas
+1 3125606441
<#CAH6LTpE1RoLVPN1aQWeJm-6nyWiovzr=hGudAmUeAGGgBAuYWg@mail.gmail.com_SafeHtmlFilter_>

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4f92ab6c-024c-4557-867f-51e514b0f465%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Cijo Thomas) #8

I hit the same issue when accessing the site using DNS name. When I am in
the machine, http:localhost:xxxx/ works though. Have not figured out the
fix for this yet. It seems like Kibana 4 CORS issue.

On Thu, Jan 29, 2015 at 3:38 PM, Konstantin Erman konste@gmail.com wrote:

Yes, Kibana 4 beta 3. And I have just one URL rewrite rule (pictured).
Were you getting the same error when it was not working for you?

https://lh3.googleusercontent.com/-oDiu_ncjJlA/VMrEJL-Qj_I/AAAAAAAAAic/so2IvrgTQbY/s1600/RewriteRule.png

On Thursday, January 29, 2015 at 3:31:56 PM UTC-8, Cijo Thomas wrote:

Can you show your URL rewrite rules ? Also are you using Kibana 4 beta 3
?

On Thu, Jan 29, 2015 at 1:09 PM, Konstantin Erman kon...@gmail.com
wrote:

Unfortunately I could not replicate your success :frowning:

Let me show you what I did in case you may be notice any difference from
your case.

https://lh6.googleusercontent.com/-HzQRKhGl9ag/VMqfkWnSF8I/AAAAAAAAAh0/SsXrJlQ2vW8/s1600/Output_Caching.png

https://lh6.googleusercontent.com/-V2VTx-iT888/VMqf0K7jChI/AAAAAAAAAh8/qC7umA0XP_U/s1600/AppPool1.png

https://lh6.googleusercontent.com/-4jL3Hyoq0QY/VMqgF7d0-II/AAAAAAAAAiE/77VOeAZP2e0/s1600/AppPool2.png

https://lh5.googleusercontent.com/-aBFCh_BZKn4/VMqgnM9ejhI/AAAAAAAAAiM/zxnsdD-VK8U/s1600/Error.png
Any ideas what I may be missing?

Thanks!
Konstantin

On Thursday, January 29, 2015 at 10:13:40 AM UTC-8, Cijo Thomas wrote:

I have been fighting with this for quite some time, Finally found the
workaround. Let me know if it helps you!

On Thu, Jan 29, 2015 at 10:12 AM, Konstantin Erman kon...@gmail.com
wrote:

Thank you for the good news! I'm a little swamped currently, but I
will definitely give it a try when I get a minute.

Just to make sure - "disable Output cache for the website" - where is
it in IIS Management Console?

On Wednesday, January 28, 2015 at 4:38:01 PM UTC-8, Cijo Thomas wrote:

Its possible to use IIS with the following steps.

  1. Disable Output cache for the website you are using as reverse
    proxy.
  2. Run the website in a new apppool, which do not have any managed
    code.

With the above two steps, kibana4 runs fine with IIS as reverse proxy.

On Saturday, December 27, 2014 at 4:19:31 PM UTC-8, Konstantin Erman
wrote:

We currently use Kibana 3 hosted in IIS behind IIS reverse proxy for
auhentication. Naturally we look at Kibana 4 Beta 3 expecting it to replace
Kibana 3 soon. Kibana 4 is self hosted and works nicely when accessed
directly, but we need authentication and whatever I do I cannot make it
work from behind reverse proxy! Early or later I get 401 accessing some
internal resource.

Wonder if anybody hit similar problem and have any insight how to
make it work.
We cannot use Shield as its price is way beyond our bounds.

Thanks!
Konstantin

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/to
pic/elasticsearch/r_uDcHR-rrw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/d089ed71-71c4-4997-93fa-2dc7125b7f49%40goo
glegroups.com
https://groups.google.com/d/msgid/elasticsearch/d089ed71-71c4-4997-93fa-2dc7125b7f49%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Warm Regards,
Cijo Thomas
+1 3125606441
<#14b380f1ef4f9e0e_CAH6LTpE1RoLVPN1aQWeJm-6nyWiovzr=hGudAmUeAGGgBAuYWg@mail.gmail.com_14b3786b590d6772_CAH6LTpEkRjF1kDbKEm5Frvwb6BBCH_Xhvm1hhKtMYtYCphrraQ@mail.gmail.com_SafeHtmlFilter_>

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/r_uDcHR-rrw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/cbf5e8d0-6769-4ef5-b625-9a6457fac86c%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/cbf5e8d0-6769-4ef5-b625-9a6457fac86c%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Warm Regards,
Cijo Thomas
+1 3125606441
<#14b380f1ef4f9e0e_CAH6LTpE1RoLVPN1aQWeJm-6nyWiovzr=hGudAmUeAGGgBAuYWg@mail.gmail.com_SafeHtmlFilter_>

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/r_uDcHR-rrw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4f92ab6c-024c-4557-867f-51e514b0f465%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/4f92ab6c-024c-4557-867f-51e514b0f465%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Warm Regards,
Cijo Thomas
+1 3125606441 <#SafeHtmlFilter_>

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAH6LTpG0QV0FbqeTOfun3avjkH96u8ONZ_HYWrS_40JzrEBO%2Bg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Konstantin Erman) #9

Well, access through localhost worked for me from the very beginning, as
well as access through LAN. But external access is also necessary, that's
where the whole issue with IIS reverse proxy stemmed from!

On Friday, February 6, 2015 at 4:30:47 PM UTC-8, Cijo Thomas wrote:

I hit the same issue when accessing the site using DNS name. When I am in
the machine, http:localhost:xxxx/ works though. Have not figured out the
fix for this yet. It seems like Kibana 4 CORS issue.

On Thu, Jan 29, 2015 at 3:38 PM, Konstantin Erman <kon...@gmail.com
<javascript:>> wrote:

Yes, Kibana 4 beta 3. And I have just one URL rewrite rule (pictured).
Were you getting the same error when it was not working for you?

https://lh3.googleusercontent.com/-oDiu_ncjJlA/VMrEJL-Qj_I/AAAAAAAAAic/so2IvrgTQbY/s1600/RewriteRule.png

On Thursday, January 29, 2015 at 3:31:56 PM UTC-8, Cijo Thomas wrote:

Can you show your URL rewrite rules ? Also are you using Kibana 4 beta
3 ?

On Thu, Jan 29, 2015 at 1:09 PM, Konstantin Erman kon...@gmail.com
wrote:

Unfortunately I could not replicate your success :frowning:

Let me show you what I did in case you may be notice any difference
from your case.

https://lh6.googleusercontent.com/-HzQRKhGl9ag/VMqfkWnSF8I/AAAAAAAAAh0/SsXrJlQ2vW8/s1600/Output_Caching.png

https://lh6.googleusercontent.com/-V2VTx-iT888/VMqf0K7jChI/AAAAAAAAAh8/qC7umA0XP_U/s1600/AppPool1.png

https://lh6.googleusercontent.com/-4jL3Hyoq0QY/VMqgF7d0-II/AAAAAAAAAiE/77VOeAZP2e0/s1600/AppPool2.png

https://lh5.googleusercontent.com/-aBFCh_BZKn4/VMqgnM9ejhI/AAAAAAAAAiM/zxnsdD-VK8U/s1600/Error.png
Any ideas what I may be missing?

Thanks!
Konstantin

On Thursday, January 29, 2015 at 10:13:40 AM UTC-8, Cijo Thomas wrote:

I have been fighting with this for quite some time, Finally found the
workaround. Let me know if it helps you!

On Thu, Jan 29, 2015 at 10:12 AM, Konstantin Erman kon...@gmail.com
wrote:

Thank you for the good news! I'm a little swamped currently, but I
will definitely give it a try when I get a minute.

Just to make sure - "disable Output cache for the website" - where is
it in IIS Management Console?

On Wednesday, January 28, 2015 at 4:38:01 PM UTC-8, Cijo Thomas wrote:

Its possible to use IIS with the following steps.

  1. Disable Output cache for the website you are using as reverse
    proxy.
  2. Run the website in a new apppool, which do not have any managed
    code.

With the above two steps, kibana4 runs fine with IIS as reverse
proxy.

On Saturday, December 27, 2014 at 4:19:31 PM UTC-8, Konstantin Erman
wrote:

We currently use Kibana 3 hosted in IIS behind IIS reverse proxy
for auhentication. Naturally we look at Kibana 4 Beta 3 expecting it to
replace Kibana 3 soon. Kibana 4 is self hosted and works nicely when
accessed directly, but we need authentication and whatever I do I cannot
make it work from behind reverse proxy! Early or later I get 401 accessing
some internal resource.

Wonder if anybody hit similar problem and have any insight how to
make it work.
We cannot use Shield as its price is way beyond our bounds.

Thanks!
Konstantin

--
You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/to
pic/elasticsearch/r_uDcHR-rrw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/d089ed71-71c4-4997-93fa-2dc7125b7f49%40goo
glegroups.com
https://groups.google.com/d/msgid/elasticsearch/d089ed71-71c4-4997-93fa-2dc7125b7f49%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Warm Regards,
Cijo Thomas
+1 3125606441
<#CAH6LTpG0QV0FbqeTOfun3avjkH96u8ONZ_HYWrS_40JzrEBO+g@mail.gmail.com_14b380f1ef4f9e0e_CAH6LTpE1RoLVPN1aQWeJm-6nyWiovzr=hGudAmUeAGGgBAuYWg@mail.gmail.com_14b3786b590d6772_CAH6LTpEkRjF1kDbKEm5Frvwb6BBCH_Xhvm1hhKtMYtYCphrraQ@mail.gmail.com_SafeHtmlFilter_>

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/r_uDcHR-rrw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/cbf5e8d0-6769-4ef5-b625-9a6457fac86c%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/cbf5e8d0-6769-4ef5-b625-9a6457fac86c%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Warm Regards,
Cijo Thomas
+1 3125606441
<#CAH6LTpG0QV0FbqeTOfun3avjkH96u8ONZ_HYWrS_40JzrEBO+g@mail.gmail.com_14b380f1ef4f9e0e_CAH6LTpE1RoLVPN1aQWeJm-6nyWiovzr=hGudAmUeAGGgBAuYWg@mail.gmail.com_SafeHtmlFilter_>

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/r_uDcHR-rrw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4f92ab6c-024c-4557-867f-51e514b0f465%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/4f92ab6c-024c-4557-867f-51e514b0f465%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Warm Regards,
Cijo Thomas
+1 3125606441
<#CAH6LTpG0QV0FbqeTOfun3avjkH96u8ONZ_HYWrS_40JzrEBO+g@mail.gmail.com_SafeHtmlFilter_>

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c38048f7-f2a3-4241-9d1d-7958c8b9a5c4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Marcus Vinicius) #10

Hi there!

I just found the solution for this problem in my case.

The problem is occurring because ISS server is classifying the request "/elasticsearch/.kibana/_mapping/*/field/source?=1453386587718" as a "potentially dangerous Request".

So, after i realized that i just change my web.config file to ignore this validation, as seen bellow:

I just added the code bellow between the tags;

<system.web>
	<httpRuntime requestPathInvalidCharacters="" requestValidationMode="2.0" />
	<pages validateRequest="false" />
</system.web>

I think it will help you.

See my full web.config file:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
	<system.web>
		<httpRuntime requestPathInvalidCharacters="" requestValidationMode="2.0" />
		<pages validateRequest="false" />
	</system.web>
    <system.webServer>
        <rewrite>
            <outboundRules>
                <preConditions>
                    <preCondition name="ResponseIsHtml1">
                        <add input="{RESPONSE_CONTENT_TYPE}" pattern="^text/html" />
                    </preCondition>
                </preConditions>
            </outboundRules>
            <rules>		
                <rule name="ReverseProxyInboundRule1" stopProcessing="true">
                    <match url="(.*)" />
                    <conditions>
                        <add input="{CACHE_URL}" pattern="^(https?)://" />
                    </conditions>
                    <action type="Rewrite" url="{C:1}://127.0.0.1:5601/{R:1}" />
                </rule>				
            </rules>
        </rewrite>
        <urlCompression doStaticCompression="false" doDynamicCompression="false" />
    </system.webServer>
</configuration>

#11

I am confused now! When I logged to my IIS servers to apply your fix, Marcus, to my surprise I have found that those two lines are already there! Now I have no idea how they got there in the first place, but I don't remember adding those manually. Could some other process add those for me? Puzzling...


(system) #12