Kibana 4 Dev environment setup


(Lantern77) #1

Hello,
I am currently trying to install Kibana 4.2.1 as a dev environment on a windows machine and unfortunateky I get error when I try to do npm install.
I am following these instructions: https://github.com/elastic/kibana/blob/master/CONTRIBUTING.md
and I hard reset back to release 4.2.1

I tried on the latest version on github as well and I get a similar issue.Except of 'splager' its 'bigfunger' not being in npm registry.

Error Message:

npm ERR! TypeError: Cannot read property 'latest' of undefined
npm ERR!     at next (C:\Users\Welcome\AppData\Roaming\nvm\v0.10.26\node_modules\npm\lib\cache.js:744:35)
npm ERR!     at C:\Users\Welcome\AppData\Roaming\nvm\v0.10.26\node_modules\npm\lib\cache.js:732:5
npm ERR!     at saved (C:\Users\Welcome\AppData\Roaming\nvm\v0.10.26\node_modules\npm\node_modules\npm-registry-client\l
ib\get.js:148:7)
npm ERR!     at C:\Users\Welcome\AppData\Roaming\nvm\v0.10.26\node_modules\npm\node_modules\graceful-fs\polyfills.js:133
:7
npm ERR!     at Object.oncomplete (fs.js:107:15)
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>
npm ERR! System Windows_NT 6.2.9200
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js"
 "install"
npm ERR! cwd C:\Users\Welcome\Documents\Github\kibana
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.6
npm ERR! type non_object_property_load
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     C:\Users\Welcome\Documents\Github\kibana\npm-debug.log
npm ERR! not ok code 0

Logs say:

1717 error 404 'spalger' is not in the npm registry.
1717 error 404 You should bug the author to publish it
1717 error 404 It was specified as a dependency of 'kibana'
1717 error 404
1717 error 404 Note that you can also install from a
1717 error 404 tarball, folder, or http url, or git url.
1718 error System Windows_NT 6.2.9200
1719 error command "C:\Program Files\nodejs\\node.exe" "C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js" "install"
1720 error cwd C:\Users\Welcome\Documents\Github\kibana
1721 error node -v v0.10.26
1722 error npm -v 1.4.6
1723 error code E404
1724 verbose exit [ 1, true ]

Edit: I also tried installing kibana 4.2.1 normally and I get this error

Error: Cannot find module 'lodash'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (C:\Users\Welcome\Documents\WebWorkSpace\kibana-4.2.1\kibana-4.2.1\src\optimize\babelOptions.j
s:1:79)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)

I tried using the lastest releases of kibana and elasticsearch(4.4 and 2.2) everything works smoothly as intended.
However, we are currently using kibana 4.2.1 and elasticsearch 2.0 and would like to keep to this version.


(Lantern77) #2

So I ended up spending a little bit more time with this,
and thought maybe my npm was out of date as I got

"npm ERR! TypeError: Cannot read property 'latest' of undefined"

So I ran

npm install npm -g

I finally tried a nvm install 0.12.7
and npm install

and those now passed and worked. I can run the dev elasticsearch using

npm run elasticsearch

However when I go to start kibana with

./bin/kibana --dev

I get this error message

PS C:\Users\Welcome\Documents\WebWorkSpace\kibana> ./bin/kibana --dev
 watching for changes  (90 files)
events.js:72
        throw er; // Unhandled 'error' event
              ^
TypeError: Invalid non-string/buffer chunk
    at validChunk (_stream_writable.js:153:14)
    at KbnLoggerJsonFormat.Writable.write (_stream_writable.js:182:12)
    at write (_stream_readable.js:583:24)
    at flow (_stream_readable.js:592:7)
    at [object Object].pipeOnReadable (_stream_readable.js:624:5)
    at [object Object].EventEmitter.emit (events.js:92:17)
    at emitReadable_ (_stream_readable.js:408:10)
    at emitReadable (_stream_readable.js:404:5)
    at readableAddChunk (_stream_readable.js:165:9)
    at [object Object].Readable.push (_stream_readable.js:127:10)
    at [object Object].Transform.push (_stream_transform.js:140:32)
    at [object Object].internals.Squeeze._transform (C:\Users\Welcome\Documents\WebWorkSpace\kibana\node_modules\good-sq
ueeze\lib\squeeze.js:31:14)
    at [object Object].Transform._read (_stream_transform.js:179:10)
    at [object Object].Transform._write (_stream_transform.js:167:12)
    at doWrite (_stream_writable.js:226:10)
    at writeOrBuffer (_stream_writable.js:216:5)
FATAL [TypeError: Invalid non-string/buffer chunk]
 server crashed  with status code 8
 optimizer crashed  with status code 1

Note I also added kibana.dev.yml


(system) #3