Kibana dev environment - npm start error

I am trying to write a plugin for Kibana 4.4.2 - that the version we are still using. I got the source code by git clone and download as zip - both have the same error when I run npm start. I also installed the latest node. But still the same. Following are the content in npm-debug.log file.

Any help is appreciated. Thanks in advance

0 info it worked if it ends with ok
1 verbose cli [ 'C:\Program Files\nodejs\node.exe',
1 verbose cli 'C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js',
1 verbose cli 'start' ]
2 info using npm@3.10.10
3 info using node@v6.10.0
4 verbose run-script [ 'prestart', 'start', 'poststart' ]
5 info lifecycle kibana@4.4.2~prestart: kibana@4.4.2
6 silly lifecycle kibana@4.4.2~prestart: no script for prestart, continuing
7 info lifecycle kibana@4.4.2~start: kibana@4.4.2
8 verbose lifecycle kibana@4.4.2~start: unsafe-perm in lifecycle true
9 verbose lifecycle kibana@4.4.2~start: PATH: C:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin;C:\dev\kibana\kibana-4.4.2\node_modules.bin;
10 verbose lifecycle kibana@4.4.2~start: CWD: C:\dev\kibana\kibana-4.4.2
11 silly lifecycle kibana@4.4.2~start: Args: [ '/d /s /c', './bin/kibana --dev' ]
12 silly lifecycle kibana@4.4.2~start: Returned: code: 1 signal: null
13 info lifecycle kibana@4.4.2~start: Failed to exec start script
14 verbose stack Error: kibana@4.4.2 start: ./bin/kibana --dev
14 verbose stack Exit status 1
14 verbose stack at EventEmitter. (C:\Program Files\nodejs\node_modules\npm\lib\utils\lifecycle.js:255:16)
14 verbose stack at emitTwo (events.js:106:13)
14 verbose stack at EventEmitter.emit (events.js:191:7)
14 verbose stack at ChildProcess. (C:\Program Files\nodejs\node_modules\npm\lib\utils\spawn.js:40:14)
14 verbose stack at emitTwo (events.js:106:13)
14 verbose stack at ChildProcess.emit (events.js:191:7)
14 verbose stack at maybeClose (internal/child_process.js:877:16)
14 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
15 verbose pkgid kibana@4.4.2
16 verbose cwd C:\dev\kibana\kibana-4.4.2
17 error Windows_NT 6.1.7601
18 error argv "C:\Program Files\nodejs\node.exe" "C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js" "start"
19 error node v6.10.0
20 error npm v3.10.10
21 error code ELIFECYCLE
22 error kibana@4.4.2 start: ./bin/kibana --dev
22 error Exit status 1
23 error Failed at the kibana@4.4.2 start script './bin/kibana --dev'.
23 error Make sure you have the latest version of node.js and npm installed.
23 error If you do, this is most likely a problem with the kibana package,
23 error not with npm itself.
23 error Tell the author that this fails on your system:
23 error ./bin/kibana --dev
23 error You can get information on how to open an issue for this project with:
23 error npm bugs kibana
23 error Or if that isn't available, you can get their info via:
23 error npm owner ls kibana
23 error There is likely additional logging output above.
24 verbose exit [ 1, true ]

Hi there, thanks for asking this question! It looks like you're using Node v6.10.0 and NPM v3.10.10, but Kibana 4 requires you to use Node v4.3.2 and NPM v2.14.21. Could you try switching to these versions and let me know if this solves your problem?

I recommend using NVM for easily changing Node versions.


Thank you and I believe you are right.
After posted the question I went to read the There is
nvm install "$(cat .node-version)" and I went to check the .node-version file. I can see it is using 4.3.2. I am in the middle of doing that. Will update back......

Thanks again

I got the version straight out. But the node-gyp kept give me errors. First it complains python not find so I installed python and it seems fine.

But now I keep getting this "unable to get local issuer certificate" error even I set strict-ssl to false false. I am behind corporate firewall.

C:\dev\kibana\kibana>npm config set strict-ssl false

C:\dev\kibana\kibana>npm install

bcrypt@0.8.7 install C:\dev\kibana\kibana\node_modules\libesvm\node_modules\bc
node-gyp rebuild

C:\dev\kibana\kibana\node_modules\libesvm\node_modules\bcrypt>if not defined npm
_config_node_gyp (node "C:\Users\yangg\AppData\Roaming\nvm\v4.3.2\node_modules\n
pm\bin\node-gyp-bin\....\node_modules\node-gyp\bin\node-gyp.js" rebuild ) els
e (node rebuild )
gyp WARN install got an error, rolling back install
gyp ERR! configure error
gyp ERR! stack Error: unable to get local issuer certificate
gyp ERR! stack at Error (native)
gyp ERR! stack at TLSSocket. (_tls_wrap.js:1016:38)
gyp ERR! stack at emitNone (events.js:67:13)
gyp ERR! stack at TLSSocket.emit (events.js:166:7)
gyp ERR! stack at TLSSocket._finishInit (_tls_wrap.js:585:8)
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command "c:\Program Files\nodejs\node.exe" "C:\Users\yangg\AppDat
p.js" "rebuild"
gyp ERR! cwd C:\dev\kibana\kibana\node_modules\libesvm\node_modules\bcrypt
gyp ERR! node -v v4.3.2
gyp ERR! node-gyp -v v3.0.3
gyp ERR! not ok

dtrace-provider@0.6.0 install C:\dev\kibana\kibana\node_modules\bunyan\node_mo
node scripts/install.js

utf-8-validate@1.2.2 install C:\dev\kibana\kibana\node_modules\karma\node_modu

node-gyp rebuild

Thanks a lot

Hmm weird. This looks like an NPM error (unrelated to Kibana). Were you able to solve this?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.