Kibana 5.2.0 not recognizing any Index Patterns

Hello,

I've freshly installed ELK & Metricbeat on Ubuntu 16.04.2 LTS, but I'm having some issues. Kibana won't recognize any index patterns from elastic search. Data is being pushed from Metricbeat into Elasticsearch (see gif)

I've followed this guide (https://github.com/xeraa/vagrant-elastic-stack) which works by the way. However, as soon as I try it on my other VM it doesn't work. Here are config files used (https://github.com/robertd/elk-config) which were extracted from a working vagrant-elastic-stack copy.

Am I missing something?

P.S. I know I have Logstash installed too, but that's for the future (Filebeat, etc) since Metricbeat is pumping to ES directly. I've also tried Filebeat through Logstash but still no luck with Kibana finding any index patterns.

Info about non-working VM:

uname -a
Linux igskbthivmsarc8 4.4.0-62-generic #83-Ubuntu SMP Wed Jan 18 14:10:15 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I can provide more info if needed.

Thanks!

I figured it out.

thanks

What was the problem? If you give more details, others who have the same issue could get some help.

I've configured nginx to point /elasticsearch to ES status url without knowing that Kibana was using the same route.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.