Kibana 5.6.3 rpm installation issues


(Josh Speer) #1

I've just installed kibana 5.6.3 using the rpm install on centos 7.4. The log directory wasn't created, so I've created it, and set the permissions. Now I've tried to start using systemctl... the service starts, however it's not responding or logging. I'm able to start the process from the CLI, and it works great, but not when using the startup scripts.


(Josh Speer) #2

I forgot to mention that I've changed it to port 80. I believe my issues is starting on such a low port. I thought running the startup script as root would be sufficient, but I don't so.


(Lee Drengenberg) #3

Hi Josh,

Although you run the command that starts the Kibana service as root, Kibana still starts up as a kibana user (which is created during installation).

I'll try setting changing the port to 80 and see if it works for me.

Regards,
Lee

UPDATE: This is the error I got in the log when I just tried changing the kibana.yml to have server.port: 80

{"type":"log","@timestamp":"2017-10-19T10:39:00Z","tags":["fatal"],"pid":14900,"level":"fatal","message":"listen EACCES 0.0.0.0:80","error":{"message
":"listen EACCES 0.0.0.0:80","name":"Error","stack":"Error: listen EACCES 0.0.0.0:80\n    at Object.exports._errnoException (util.js:1018:11)\n    at
 exports._exceptionWithHostPort (util.js:1041:20)\n    at Server._listen2 (net.js:1245:19)\n    at listen (net.js:1294:10)\n    at net.js:1404:9\n
 at _combinedTickCallback (internal/process/next_tick.js:83:11)\n    at process._tickCallback (internal/process/next_tick.js:104:9)","code":"EACCES"}

From some pages I've read, the right solution here is really to use something like iptables or firewalld to map incoming port 80 to the Kibana running on port 5601. I haven't tested that yet. If you're able to try that please us know if it works for you. If you have problems I'll try to do it as well.

Regards,
Lee


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.