I moved from Kibana 4 to 5 and Kibana won't start


(Steven Pine) #1

I am running on CentOS 7
I installed Kibana using the tar.gz file.
I proceed to the bin directory and start kibana ./kibana
It never starts. Logging reports:
net.js:10
const cares = process.binding('cares_wrap')

Error: EFILE
at Error (native)
.......
/opt/kibana-5.0.0-linux-X86_64/node_modules/chalk/node_modules/supported-color/index.js:29:13

Can someone please help by telling me what is going on and how to fix this.
4.x was simple I just ./kibana and it would start right out of the box.


(Shaunak Kashyap) #2

Can you post the link where you got the tar.gz file from? I'm asking because there isn't a node package called supported-color.


(Steven Pine) #3

Sorry the path is supports-color
I also tried installing the rpm and get the same failure.
CentOS is not setup supporting 32 bit color only less 24,16 ....
Is this failing due to the color setting of the OS if so can Kibana be changed to support 24 bit


(Steven Pine) #4

So I started kibana as root and it runs.
Looks like this is a net.sj binding issue.
Now the question is "How do I run Kibana as a non-root user"?


(Adrien Bigot) #5

Hello,

Did you tried to set :
logging.dest: /tmp/kibana.log
logging.verbose: true

in your kibana.yml

And see what happened in this log file ?

Maybe it can help, I also had a similar problem when I've set server.port to a port below 1024. Only root can bind such ports.

Regards,

BIGOT Adrien


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.