Kibana 5 won't start after install


#1

Details:

  • CentOS 7 (10 nodes)
  • Kibana 5.1.2 (installed the rpm)
  • ES 5.1.2

I've installed elasticsearch on ten nodes and all of them have succesfully joined the cluster. When I enter localhost:9200 in my browser I get the "You Know, for Search" message. Next I've installed Kibana with yum package manager, started kibana by systemctl start kibana. Went to my browser and entered localhost:5601 but nothing is happening. Connection time out. I did not alter kibana.yml because it should work straight out of the box if I'm correct?

Previously I had Kibana 4 and Elastic 2.4 running on the machines but I uninstalled those before I installed the latest releases. When I perform curl localhost:5601 I get:

<script>var hashRoute = '/app/kibana';
var defaultRoute = '/app/kibana';

var hash = window.location.hash;
if (hash.length) {
  window.location = hashRoute + hash;
} else {
  window.location = defaultRoute;

Or netstat -natp | grep 5601

tcp        0      0 127.0.0.1:5601          0.0.0.0:*               LISTEN      3386/node

(Lee Drengenberg) #2

Hi Denny,
Are you using a browser on the Kibana server? The default server.host used to be 0.0.0.0 but now is localhost.

Here's the section of the kibana.yml;

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
#server.host: "localhost"

So to use Kibana from another machine change it to 0.0.0.0 or to the IP of the machine.

Let me know if that doesn't work for you.

Regards,
Lee

P.S. You can also check the kibana log, probably /var/log/kibana/kibana.stdout to see the log message that says what IP and port it's listening on.


#3

Thanks! Changing it to 0.0.0.0 in kibana.yml worked!


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.