Kibana startup fails for kibana-4.4.1-1.x86_64


#1

Hi,

After installing, run Kibana from the install directory: bin/kibana and I got following error:

Error: Cannot find module '/opt/kibana/src/src/utils/packageJson'

you can see it has double /src in the path.

Please give a help,

thanks


(Lee Drengenberg) #2

Can you describe what you downloaded and how you installed it?

Are you on Ubuntu 14.x?

Did you download and untar this?
https://download.elastic.co/kibana/kibana/kibana-4.4.1-linux-x64.tar.gz

Or did you follow instructions here?
https://www.elastic.co/guide/en/kibana/current/setup.html#install

Thanks,
Lee


#3

Yes, I follow the instruction and used yum to install it on CentOS


(Lee Drengenberg) #4

If you used yum to install the rpm you might want to start the service with service kibana start

It sounds like you're starting it by going to /opt/kibana and running ./bin/kibana ?

I just uninstalled my 4.4.0 and then installed 4.4.1 on CentOS 7.2.1511 using yum. It starts for me using either method above.

If you haven't tried both methods could you please see if you get the same error in both cases? In the case of starting the service (using sudo or as root) you would get messages in /var/log/messages and when you start with ./bin/kibana you should get the output in your console.

Thanks,
Lee


#5

I installed 4.4.1 on CentOS 6.5. I tried both cases to start kibana and got same error messages.
one is from console and one got from /var/log/kibana/kibana.stderr.

Thanks,

Carlos


#6

after I using yum to remove kibana and clean all the directories, then install it again. new I can start it no problem.

thanks,

Carlos


(Lee Drengenberg) #7

Great to hear! Have fun!


(system) #8