Kibana Install Error - should not run as root

Elk Stack newbie here... When I install Kibana on Centos 8 I get an error on install saying that I should not run ./bin/kibana as root. Do I need to create a specific user called "Kibana" instead of running as sudo? When I run it as current user "elkstackadmin" I get errors that Babel could not write cache to file /kibana-7.6.0-linux-x86_64/optimize/.babel_register_cache.json due to a permission issue. Cache is disabled...

Any insight on this would be extremely helpful.



You can either create a new user or give the elkstackadmin user ownership of the kibana installation, with chown -R elkstackadmin /kibana-7.6.0-linux-x86_64

You can - should - also use the RPM repo to install it, it'll create the user for you.

Thanks Mark,

Are you referring to the method where you manually add the repo to yum.repos.d

Create a file called kibana.repo in the /etc/yum.repos.d/
then sudo yum install kibana


the method where you download the rpm:

shasum -a 512 kibana-7.6.0-x86_64.rpm
sudo rpm --install kibana-7.6.0-x86_64.rpm

Sorry the elastic site is not very clear on which method is best to use and super convoluted to try and figure out. I've pretty much built the server like 4 times now. "Thank the lord for VMWare!"


I rebuilt the server last night but passed out before I coulds try this. Sine the elastic site isn't very clear on which way to install/configure should I use the (Add repo to yum.repos.d or download the rpm method). Which is best practice?


We provide options so that people can pick what they prefer.

If you aren't sure, use the repos.

Thanks Mark, I just wasn't sure if one way was better/standard over the other. I'm a newbie to ELK stack. I will try the method of manually adding the repos by creating a kibana user and installing under the kibana user.

You need to add the repo as the root user. Then when you install the package from the repo it will create all the users it needs to run Kibana.

Thanks Mark, I have elasticsearch and kibana installed. Next is to install metricbeats, do I need to install this on the same server or metricbeats goes on the clients?

Depends what you are monitoring. If it's system metrics then you would want both, so you can monitor your clients and the Kibana host.

Ok that makes sense because now I finally got Kibana loaded on firefox. Of course this is the local server to where elasticsearch, kibanan, and now metricbeats is installed. Gotta install logstash tonight or tomorrow.


Thank you for all the help. I was able to get this up and running finally. However, I'm getting high CPU from Java like 275% CPU when I run top. Not sure what could be causing it as the only thing that required Java was logstash and the only thing I have reporting from the ELK stack is the ELK stack server itself. Thoughts on what would be causing this and how to fix? Also should I be concerned?



Not sure sorry, checking the Logstash logs might help.

Ok, that didn't helps. I will look through the other posts.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.