Kibana 5 IIS reverse proxy


(Steve A ) #1

Hi everyone,

I'm blocked about the configuration of kibana5 behind a IIS reverse proxy.
I'm trying to redirect myserver/kibana5/ to localhost:5602 (my kibana is cfg with this port because we have two kibana for moment).
When i'm trying to access to my kibana throught myserver/kibana5/, the url is modified to myserver/app/kibana so it doesn't work.
Here my IIS cfg :
< ?xml version="1.0" encoding="UTF-8"?>
< configuration>
< system.webServer>
< rewrite>
< rules>
< clear />
< rule name="Redirect to Kibana v5" enabled="true" stopProcessing="true">
< match url="(.)" />
< conditions logicalGrouping="MatchAll" trackAllCaptures="false" />
< action type="Rewrite" url="http://localhost:5602/{R:1}" logRewrittenUrl="false" />
< /rule>
< /rules>
< rewriteMaps>
< rewriteMap name="(.
)" />
< /rewriteMaps>
< /rewrite>
< /system.webServer>
< /configuration>

Here my kibana cfg

# Kibana is served by a back end server. This setting specifies the port to use.
server.port: "5602"
# This setting specifies the IP address of the back end server.
server.host: "0.0.0.0"
# Enables you to specify a path to mount Kibana at if you are running behind a proxy. This setting
# cannot end in a slash.
server.basePath: "C:\soft\kibana-5.1.1-windows-x86"

(Lukas Olson) #2

Could you try setting server.basePath to myserver/kibana5?


(Steve A ) #3

Hi,

Thanks for the reply.
I have set my basebath to "/kibana5" and I can access to Kibana but I have the menu on the left and a blank page.
It seem not loaded correctly .

Fixed by adding in webconfig :

< system.web>
< httpRuntime requestPathInvalidCharacters="" requestValidationMode="2.0" />
< /system.web>


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.