Kibana 5 X pack Segmentation fault


(Manoj) #1

Hi,

I have installed ELK 5 and started Elasticsearch and Kibana. I could able to view Kibana dashboard.

Next I stopped both and Installed X pack with below command:
bin/elasticsearch-plugin install file:///tmp/x-pack-5.0.0.zip
bin/kibana-plugin install file:///tmp/x-pack-5.0.0.zip

Xpack for elastic search got installed successfully with below message:
[root@ip-10-34-70-60 elasticsearch]# bin/elasticsearch-plugin install file:///tmp/x-pack-5.0.0.zip
Picked up _JAVA_OPTIONS: -Xmx2048m -Xms1024m
-> Downloading file:///tmp/x-pack-5.0.0.zip
[=================================================] 100%
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: plugin requires additional permissions @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

  • java.lang.RuntimePermission accessClassInPackage.com.sun.activation.registries
  • java.lang.RuntimePermission getClassLoader
  • java.lang.RuntimePermission setContextClassLoader
  • java.lang.RuntimePermission setFactory
  • java.security.SecurityPermission createPolicy.JavaPolicy
  • java.security.SecurityPermission getPolicy
  • java.security.SecurityPermission putProviderProperty.BC
  • java.security.SecurityPermission setPolicy
  • java.util.PropertyPermission * read,write
  • java.util.PropertyPermission sun.nio.ch.bugLevel write
  • javax.net.ssl.SSLPermission setHostnameVerifier
    See http://docs.oracle.com/javase/8/docs/technotes/guides/security/permissions.html
    for descriptions of what these permissions allow and the associated risks.

Continue with installation? [y/N]y
-> Installed x-pack

Next when I do for kibana I get segmentation fault as below,

[root@ip-10-34-70-60 kibana]# bin/kibana-plugin install file:///tmp/x-pack-5.0.0.zip
Attempting to transfer from file:///tmp/x-pack-5.0.0.zip
Transferring 72364732 bytes....................
Transfer complete
Retrieving metadata from plugin archive
Extracting plugin archive
Extraction complete
Optimizing and caching browser bundles...
Segmentation fault

When I started both Elasticsearch and Kibana and tried to load dashboard I get "This page can’t be displayed" error.

I tried with other linux as well.. without x pack my kibana is loading, once x pack is installed Kbana is giving "This page can’t be displayed". Please help.


Xpack installation error - segmentation fault
(Thomas Neirynck) #2

hi @manojvenkat,

do you get the same issue when you install directly from the hosted X-pack version?

bin/kibana-plugin install x-pack


(Manoj) #3

Hi @thomasneirynck,

We have some firewall issue in our organization. So not able to directly install from hosted X-pack version. That's reason I tried the other Manual way.

For Elasticsearch installation gets done without issue, facing problem for Kibana only.

Regards.


(Thomas Neirynck) #4

I can't reproduce. I tested on Ubuntu 16, 64bit. What linux are you on?

When you are trying this on another device, and see the "page can't be displayed" error, what do you see in the browser console logs or the Kibana server log?


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.