Kibana 6.1.0. and newer starts with error


#29

I've managed to get access to my working environment.

You're right. I've changed path from absolute to relative in my service configuration & it started to work.
Thanks again.


(Kim Kruse Hansen) #30

Hi

Thats good news. I have been upgrading some clusters myself today to 6.1.1 and my workaround seems to work so far.

@CJ , are you still monitoring this discussion?

Regards
Kim


(Samar Rizvi) #31

@Kim-Kruse-Hansen @fragatina @Mojster
I tried all of the above workarounds, but none worked. The drive where Windows is installed usually has permission issues with many apps. So, I copied Kibana to another drive (it was earlier in C: drive), and viola! Kibana works.


(Kim Kruse Hansen) #32

Hi

@Marius_Dragomir ,@cjcenizal

Any words on this issue? More people are facing the issue and we have a great way of reproducing and how to work around it. Will it be fixed in 6.1.2 ?

Let us know

Regards
Kim


(Viorel Florian) #33

I tried starting kibana-6.1.1 and I am encountering the same issue under Windows 2008:

Error: Uncaught TypeError: (0 , _reactcss.handleHover) is not a function
(http://localhost:8280/bundles/kibana.bundle.js?v=16350:67) at window.onerror (http://localhost:8280/bundles/commons.bundle.js?v=16350:45:8728)

I tried deleting the optimize folder and starting kibana from the root directory:

d:\ELK\apps\kibana-6.1.1-windows-x86_64

with the command:

bin\kibana.bat

I even tried to weed-out a permission issue by setting the owner of the kibana folder to "Everyone".
Alas, the issue persists. Any thoughts?


(Tim Sullivan) #34

Hi, I came to this topic from Kibana 6.1.1 Fatal Error at start and I think there are a few different issues going on. The few that I can think of are:

  1. Installing or removing a plugin while Kibana is running. Kibana must be stopped when a plugin is installed. Kibana discovers all the plugins at startup time, so plugins have to be installed or removed while Kibana is not running.
  2. X-Pack or some other plugin not being fully installed. If plugin installation gets aborted before it's finished then it may show as installed even though it is in a broken state. You can remove and try installing the plugin again. Make sure Kibana is restarted after the plugin is reinstalled. Sometimes removing the optimize directory and restarting Kibana could act as a shortcut.
  3. Running a bin/kibana-plugin install plugin-name command from a different working directory. The plugin installer has to be run from the Kibana installation path.

@Kim-Kruse-Hansen if this is what you need to do to run Kibana with X-Pack, it indicates to me that the Kibana Service you're launching is somehow starting Kibana without it running the optimizer first. (Sorry, but I'm not sure how that would happen.) So running bin/kibana manually up front does the optimization, and then Kibana can be restarted by the service successfully, because optimization was done. If you add any other plugins or change certain config settings (such as disabling a feature or changing the server.basePath setting) then you'd need to run bin/kibana manually again to force it do to the optimization again.


(Kim Kruse Hansen) #35

Hi Tim

Sorry , but there is no service running ,or no aborted plugin installation. This is always a brand new install.

There is something fundamental changed something n the Kibana installation starting from 6.1.0. I am using same installation scripts as from way back to 2.5.3.

First msg is always "Optimizing and caching ..."

I have found a way around this problem but as I am sure , you will notice , several other users are facing the same problem.

Only reliable way of getting it to work, once it has gone bad is to remove optimze directory and run bin\kibana from kibana root. Then you can start the service.

Regards
Kim


#36

@tsullivan:

I'm running straight Kibana with no plugins and I'm not using X-Pack .
So my and @Kim-Kruse-Hansen issues are not listed on your list.

It's only a startup dir issue.


(Tim Sullivan) #37

Hi Kim,

Can you check the before and after permissions of the optimize directory and the files inside it? It may be that you're required to run bin/kibana manually so the Kibana service runs as a user with your interactive user privileges, and has the permission to properly create the optimize directory.

If that is the problem, check that the Kibana directory and all the files it contains are owned by the same user account used for running the Kibana service.

Sometimes the core Kibana files are owned by an interactive user account, but they need to be owned by the same user that runs the Kibana service, so that the service can write new files.


(Viorel Florian) #38

Hi @Kim-Kruse-Hansen/@tsullivan ,
I tried theworkaround with removing optimize directory and run bin\kibana.bat from the root dir. But the error did not go away. I tried this with or without xpack, from clean, fresh copy.
Regards,
Vio


#39

In my example I did not touch any permissions.

But OK, I've change my paths and now it's working.
I'm considering to write my own windows service installer as it's written for filebeat and so get rid of Windows Service Wrapper.


(Kim Kruse Hansen) #40

Hi Tim

There is no issue with permissions . I always run the install scripts from an admin account.

There is a difference between the contents of the optimize on a good and a bad installation.

On a working 6.1.1 installation with x-pack , i have 9.124.192 bytes in .cache and 38.254.227 bytes in bundles.

Can't someone look into what was changed in 6.1.0 in regards to compile/optimize step. 6.0.1 was the last good working version.

Regards
Kim


(Tim Sullivan) #41

And just so we're ruling out the possibility of permissions, this admin account is the same user account that the service script uses to launch Kibana, correct?

There are a few team members discussing the issue in a backchannel. @Marius_Dragomir wants me to say he'll be back tomorrow and is going to look into the uploaded optimize folder that @Mojster provided.


(Kim Kruse Hansen) #42

Correct

Good news. Looks like something related to the startup directory logic.

Regard
Kim


(Kim Kruse Hansen) #43

Hi Viorel_Florian

Try this exactly as written.

Launch a new command prompt in admin mode.
cd c:\elastic\kibana <<< or whatever your kibana install directory is
rd optimize /s /q
bin\kibana
When kibana is running , connect with browser to http://localhost:5601

If that doesnt work please have a look at optimize directory. How many bytes in .cache and in bundles ?

Regards
Kim


(Viorel Florian) #44

Tried it and still the same result
Optimize dir stats:
.cache - 5,842,526 bytes in 1,403 file(s), in 3 directories
bundles - 14,441,444 bytes in 55 file(s), in 7 directories


#45

Hi,

Just confirming the same issue with a clean install of Kibana 6.1.0 on Windows 2008 R2. No plugins involved, no X-Pack either. Tried all steps described in posts above to no avail.

Uncaught TypeError: (0 , _reactcss.handleHover) is not a function (http://#erver#:5601/bundles/kibana.bundle.js?v=16350:67)
Version: 6.1.1
Build: 16350
Error: Uncaught TypeError: (0 , _reactcss.handleHover) is not a function (http://#SERVER#:5601/bundles/kibana.bundle.js?v=16350:67)
at window.onerror (http://#SERVERS#:5601/bundles/commons.bundle.js?v=16350:45:8728)

Regards,
Karsten


(Tim Sullivan) #46

Hi Kim, great to see that the issue can be detangled a bit further. Can you clarify what you mean by "startup directory logic"?


(Kim Kruse Hansen) #47

Hi Tim

Try this to reproduce on windows.

install 6.1.1 into c:\elastic\kibana
install x-pack
cd c:\elastic\kibana
rd optimize /s /q
and then this command
c:\elastic\kibana\bin\kibana.bat

This is consistent on my machine to reproduce the error.

I get 9.124.192 in cache and 34.421.296 in bundles.

Regards
Kim


(Kyrylo Semenko) #48

Hi

I don't sure, but I think it is too long time between 'Optimizing and caching bundles' and 'Optimization of bundles for graph' records in the log (about 8 minutes):

c:\prg\logstash\kibana\kibana-6.1.1-windows-x86_64>rd optimize /s /q

c:\prg\logstash\kibana\kibana-6.1.1-windows-x86_64>bin\kibana
  log   [08:35:19.538] [info][optimize] Optimizing and caching bundles for graph, monitoring, ml, apm, kibana, stateSessionStorageRedirect, timelion, login, logout, dashboardViewer and status_page. This may take a few minutes
  log   [08:43:08.779] [info][optimize] Optimization of bundles for graph, monitoring, ml, apm, kibana, stateSessionStorageRedirect, timelion, login, logout, dashboardViewer and status_page complete in 469.24 seconds
  log   [08:43:08.865] [info][status][plugin:kibana@6.1.1] Status changed from uninitialized to green - Ready
  log   [08:43:08.933] [info][status][plugin:elasticsearch@6.1.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch

I installed Kibana and Elasticsearch yesterday evening. It is my first installation of Kibana. I downloaded zip and this is my directories structure:
logstash

Removing of 'optimize' directory does not work for me, error message remains:

Please help me.

Kyryl