Kibana 6.1.1 Fatal Error at start


#1

I've updated to latest Elasticsearch/Kibana to 6.1.1 and go the following Fatal error in Kibana (which prevents to display anything else besides the following error in the browser). I don't have any customized plugins installed.

"
TypeError: undefined is not an object (evaluating 'Observable_1.Observable.prototype') (http://<ip_address>:5601/bundles/kibana.bundle.js?v=16350:112)

Version: 6.1.1
Build: 16350

Error: TypeError: undefined is not an object (evaluating 'Observable_1.Observable.prototype') (http://<ip_address>:5601/bundles/kibana.bundle.js?v=16350:112)
onerror@http://<ip_address>:5601/bundles/commons.bundle.js?v=16350:45:8737
"

It used to work fine with 6.0.0 version


Kibana 6.1.0. and newer starts with error
Kibana 6.1.0. and newer starts with error
#2

I've got similar issue with 6.1.0 & 6.1.1, but mine's with react and not prototype.
You can read here: Kibana 6.1.0. starts with error

Try deleting optimeze folder. It did help in one case.


#3

Thanks Mojster, removing the .cache on the optimize folder didn't help with me either (I have the same error). Nor removing the optimize folder (with this kibana fails to load).

I've use safari 11.0 in mac.

In chrome 62.0 (also for mac), I get the same error as you with prototype:
''
Uncaught TypeError: Cannot read property 'prototype' of undefined (http://<ip_addr>:5601/bundles/kibana.bundle.js?v=16350:112)

Version: 6.1.1
Build: 16350

Error: Uncaught TypeError: Cannot read property 'prototype' of undefined (http://<ip_addr>:5601/bundles/kibana.bundle.js?v=16350:112)
at window.onerror (http://<ip_addr>:5601/bundles/commons.bundle.js?v=16350:45:8728)
"


(Tim Sullivan) #4

Hi @fragatina , I see that you wrote you "don't have any custom plugins installed," but do you have any standard plugins like X-Pack? If so, try uninstalling and re-installing the plugins that you have.


(Gourav Kumar) #5

Do we have a solution for the above issue? Even I am getting the same error on opening Kibana. Any suggestion would be much appreciated.

OS :- Windows 2012 R2 64 bit.
Kibana: 6.1.1


(Winfield Henry) #6

Hello,

Same issue here.
64bit Windows 10
ES 6.1.1
KB 6.1.1 and 6.1.0 have similar isssue:
"Uncaught TypeError: (0 , _reactcss.handleHover)"

No plugins installed. This was a completely new from .zip installation of ES and KB.
KB 6.1.0 produces same error
KB 6.0.1 works properly.


#7

@Gourav_Kumar & @Winfield_Henry:

Both of you are getting an similar error than this one, but it's not the same.
Your's got solved in the thread I mentioned above.


(Winfield Henry) #8

@Mojster

Your solution in the other thread seems aimed at the kibana windows service start and the paths chosen for that.

I am starting from an admin console using the kibana.bat file. Kibana starts and is running on 5601, but throws the reactcss.handleHover uncaught exception when accessing via browser.

Also, deleting the optimize directory has no effect. It regenerates and the error is still there.


(Tim Sullivan) #9

I replied to the other topic (Kibana 6.1.0. starts with error) and offered some ideas about why these problems could be happening.


(system) #10

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.