Kibana 6.1.1 password setup failed, now prompted for user /password


(Greg Sullivan) #1

Fresh install of Elastic 6.1.1 setup Kibana (Windows 2016), had it working until I tried to configure passwords, the app failed to update the kibana user but the others appeared to work.
I did enter the password I tried to give it in the kibana.yml file Kibana appears to start ok, but when I launch the web site it prompts for the user password.
I've installed the 1 year basic license.
Is it possible to reset the password or clear it and try again?

Unexpected response code [500] from calling PUT http://10.100.115.88:9200/_xpack/security/user/kibana/_password?pretty
Possible next steps:

  • Try running this tool again.
  • Check the elasticsearch logs for additional error details.
  • Use the change password API manually.

ERROR: Failed to set password for user [kibana].

Kibana is on a separate vm from Elastic and Logstash.


(Mark Walkom) #2

A Basic license doesn't include the Security functionality, so you don't need to reset anything.


(Greg Sullivan) #3

ok, so two of the password were updated and Kibana wants to authenticate, how do I get it back to no security so I can continue?


(Tim Vernum) #4

If you really have a basic license installed, then there are no passwords anymore.

To confirm that, you should be able to access http://10.100.115.88:9200/_xpack without being prompted for a password.

Kibana should automatically detect that your server does not require a password, but you could also try removing the elasticsearch.password value from your kibana.yml.


(Greg Sullivan) #5

That url prompted my for user/pass and I removed the password setting in the yml file.
{"error":{"root_cause":[{"type":"security_exception","reason":"failed to authenticate user [elastic]","header":{"WWW-Authenticate":"Basic realm="security" charset="UTF-8""}}],"type":"security_exception","reason":"failed to authenticate user [elastic]","header":{"WWW-Authenticate":"Basic realm="security" charset="UTF-8""}},"status":401}


(Tim Vernum) #6

This means that your basic license did not get installed.

What procedure and tools did you use when you tried to install the licence?
Note that when you try to go from trial to basic that reduces your set of features, and the licence install process requires you to acknowledge that. Perhaps you missed that step?


(Greg Sullivan) #7

I followed the directions for using powershell to install it.
So do I need to start over?


(Tim Vernum) #8

It seems that way from what you have told us.

Install the licence again, and make sure you read the instructions about the acknowledge parameter.


(Greg Sullivan) #9

ok, no problem. I am learning more all the time.
This can be closed. I'll deploy another set of vm's and try again.
thanks


(system) #10

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.