Kibana 6.1 Cannot access nor delete index pattern


#1

Hi Everyone,

I get this error while accessing an existing index pattern - the page for the index simply does not load. This index pattern does have a lot of fields, 1700 of them.

Is the error the result of too many fields or is this a bug? Either case, how do I overcome this error?

Payload content length greater than maximum allowed: 1048576

 Less Info
OK
Error: Payload content length greater than maximum allowed: 1048576
    at http://obpqzdbt006.usnycbt.amrs.bankofamerica.com:9000/bundles/kibana.bundle.js?v=16337:42:40912
    at processQueue (http://obpqzdbt006.usnycbt.amrs.bankofamerica.com:9000/bundles/commons.bundle.js?v=16337:29:132456)
    at http://obpqzdbt006.usnycbt.amrs.bankofamerica.com:9000/bundles/commons.bundle.js?v=16337:29:133349
    at Scope.$digest (http://obpqzdbt006.usnycbt.amrs.bankofamerica.com:9000/bundles/commons.bundle.js?v=16337:29:144239)
    at Scope.$apply (http://obpqzdbt006.usnycbt.amrs.bankofamerica.com:9000/bundles/commons.bundle.js?v=16337:29:147018)
    at done (http://obpqzdbt006.usnycbt.amrs.bankofamerica.com:9000/bundles/commons.bundle.js?v=16337:29:100026)
    at completeRequest (http://obpqzdbt006.usnycbt.amrs.bankofamerica.com:9000/bundles/commons.bundle.js?v=16337:29:104697)
    at XMLHttpRequest.xhr.onload (http://obpqzdbt006.usnycbt.amrs.bankofamerica.com:9000/bundles/commons.bundle.js?v=16337:29:105435)

(Felix Stürmer) #2

Hi @ld_pvl,

this is a safeguard put into place to protect the Kibana server from denial of service due to overly large requests. You can adapt the limit to your requirements by adjusting the setting server.maxPayloadBytes in your kibana.yml. Please be aware that increasing the limit by a lot might cause other components in the path of communication to bail out, such as firewalls, proxies and the browser. If you only require a limited subset of fields you might be able to significantly reduce the payload size by filtering out large fields using the "source filters" in the index pattern management:


#3

Thanks a lot Felix.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.