Kibana 6.x throws FATAL error for 'action.search.shard_count.limit'


#1

I am running my own dockerized setup to install all necessary Elastic-Stack components through debian packages in a "fresh" debian container.

Elasticsearch and the indices are starting fine in version 6.x

Starting with version 6 the kibana container does not start at all and exits immediately with the following error message:

kibana | FATAL "action.search.shard_count.limit" setting was not applied. Check for spelling errors and ensure that expected plugins are installed and enabled.
kibana exited with code 64

Tried many things to get it starting again:

  • Setting a transient action.search.shard_count.limit
  • Setting action.search.shard_count.limit to "null"
  • Backing up old .kibana indices and starting with no .kibana index in order to start "with a clean slate"

The message still shows up and I have no clue where and how this setting gets involved.
Anything to be set in the cluster to start kibana again?


(Tim Roes) #2

Hi,

it seems like you put a setting action.search.shard_count.limit into your kibana.yml that is unknown. In that cases Kibana refused to boot up since 6.0. You need to remove that setting from your kibana.yml. Then it should start up again.

Cheers,
Tim


#3

Hi Tim! :sunglasses:

That finally brought the solution. I always checked the kibana.yml in the wrong location. The docker config included another version of the file. Thanks a lot for the quick nudge in the right direction.

Thanks,
Christian


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.