Kibana 7.12 Discover: Document JSON view displays nested values separately and unsorted

Hello,

After upgrading to Kibana v7.12.0, in Discover, fields of documents displayed in JSON view are unsorted and not visibly collected in the objects they are stored in. That's a pain in the ass when trying to grasp the data at a glance, which was very convenient before 7.12.0. (Sorry for the language but this is absolutely enervating!)

Is there a setting to disable this messy display?

I think you are looking for this feature request: [Discover] Add _source tab to doc viewer · Issue #95946 · elastic/kibana · GitHub

For now you can switch back to the old way of fetching data by setting the discover:searchFieldsFromSource advanced setting in Stack management.

Thanks @flash1293, with the settings change it's readable again.

@sandbender There are some features that you won't see if you use _source only: Discover uses the fields API in 7.12 | Elastic Blog

Thanks @wylie, I skimmed through that. Looks all great but 'unfortunately' (for the potential love story between fields API and me) I need to see data (for debugging) in a way that is quick-snap and simple.

@timroes suggestion over here [Discover] Add _source tab to doc viewer #95946 for replacing the JSON tab in Discover with something more raw/readable would be very much appreciated. Probably by anyone who trains their eye on visual patterns to scan through 'raw' data...