Discover JSON missing _source field

Hi,

We reinstalled Kibana and Elastic with 7.12 and are accustomed to look at certain documents through just pure json, since it has a specific order and grouping. After the upgrade, the JSON tab seems to "pretty print" the json or such, flattening the object to one level making it impossible to get a good visual on the data point. It also seems to put each data point in an array.

Screenshot 2021-03-31 at 16.02.26

When inspecting the API request made by Kibana, I noticed that _source is set to false. "_source": false, and _source is never returned with the response. When I ran the exact same request through curl but change _source to true, it does indeed return _source as well.

Is there any way to change so that either _source is available through the JSON tab under Discovery, or so that the data in general can be shown closer to the original source?

Starting in 7.12, discover will pull data from fields API instead of _source. You can return to using _source by setting the advanced setting discover:searchFieldsFromSource

1 Like

We are looking into adding a _source viewer back to Discover, here is the issue you can follow: [Discover] Add _source tab to doc viewer · Issue #95946 · elastic/kibana · GitHub

2 Likes