Kibana Discover Json


(Dhanashree Zope) #1

Hi,
On discover tab i have created columns using the toggle column in table functionality.Now on clicking on a specific row at the leftmost side i am getting a dropdown kind of thing which is giving me the entire data for that particular record in two ways table or json.So in the json i am getting certain default fields apart from my loaded json fields.How can i remove those default fields for a particular saved search.


(Marius Dragomir) #2

Hello,
The best way to do this is to use Source Filterning from the Management -> Index Patterns -> Source Filters. Setting a source filter will limit the fields that are returned in the requests from Elasticsearch so you'll only get the fields that you want. in the JSON.


(Dhanashree Zope) #3

Hi @Marius_Dragomir
Can you please help me with the syntax like what changes i will have to do while setting a source filter.


(Marius Dragomir) #4

just type the name of the fields that you don't want displayed and then click on Add. It will be added to the list and excluded from results.


(Dhanashree Zope) #5

Hi, @Marius_Dragomir
Actually alongwith the source fields i wish to remove _index,_type and similar fields which were auto created by kibana. Is there a way to achieve that?


(Marius Dragomir) #6

Those are fields used internally by Elasticsearch, but you should be able to filter them as well using the source filters.


(Dhanashree Zope) #7

Yes i disabled the metafields from settings so now i am not getting them in the table but at json i am getting those.While adding _index and similar fields in source filters i am getting "The source filter doesn't match any known fields"


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.