How to remove standard fields from Kibana search results?


#1

Every Kibana discovery search returns actual document fields plus some internal Elasticsearch fields, such as _id, _index, _score, _type. The question is how to prevent those internal fields from showing up in results? They only obscure important fields in my case .

I'm looking for a way to configure Kibana 4 to not even request those fields from Elastic or if it is not possible, then hide them in discovery search results table.

Any ideas?

Thank you!
Konstantin


(Mark Walkom) #2

I don't think you can, or at least, I cannot find anything.


#3

@konste @warkolm
how about the kibana, advanced setting , metaFields .
It states:

Fields that exist outside of _source to merge into our document when displaying it
_source, _id, _type, _index, _score

can't we just edit them out and achieve what @konste asked for?


(Shelby Sturgis) #4

yahoo is correct. simply go to Advanced Settings, under metafields, remove _id, _type, _index, and _score, and _source if you like to remove those from the Discover table view.

Then save when done.


#5

As a matter of fact I have discovered the possibility to remove unneeded fields from metaFields and it even worked for me... for some time. I have not reported it back to this thread, because literally next day after I did exactly this change _id, _index, _score and _type came back to my Discover output and stay there since then!

While writing that I decided to do a simple experiment - reset metaFields setting to default (nothing changed in Discover output) and then remove unneeded fields again. Now they disappeared from Discover output! I wonder how long this effect would last.

Feels like there is obscure bug in Kibana which causes it to use default value of this field regardless of configuration after some event. What event that is - still a mystery.

I will report back if the change would stick (or not).

Thank you!
Konstantin


#6

Hi @konste
I had the same experience. They disappear then they appear again.
Currently the advance setting for Meta Fields is empty. However, these items still appear in the discover panel.
I tried restarting kibana, and deleted the index from kibana and reload again.
They are still there!


Hide fields with underscore
#7

But if you reset metaFields to default and then clear it again - they disappear! I think it is worth opening a bug.


#8

yes they disappear for a shortwhile. something bring them back!


(Eugene Prokopiev) #9

created https://github.com/elastic/kibana/issues/6104


#10

Ok, we have new recipe from Rashid's answer - reset MetaFields to default, edit them again to desired state, then refresh index pattern. It may make the changes to stick. I just did it and keep an eye on it.


#11

Nope, it did not work. meta fields returned after less than a day :frowning:


(Joseph Dissmeyer) #12

I also experience the same issue. Refreshing the index pattern does not appear to do anything either. I'll post to the #6104 issue as well.


(system) #13