[kibana 7.13]can not support the --allow-root when using the kibana-keystore

when I used the following command to create the Keystore, I got the following error.

/usr/share/kibana/bin/kibana-keystore create --allow-root
kibana.keystore located in the data folder is deprecated. Future versions will use the config folder.
error: unknown option '--allow-root'

who can help me?
thanks

@harry_010 where have you found --allow-root as an available param? I don't think that one exists in that CLI.

Cheers

we are using this option for a long time. the last version is 7.9. this works well.

@harry_010 I can't find that argument available for 7.13 It would be better to not run this as root.

Cheers

thanks. another problem.
the cli still support the creates parameter? you know I want to put the keystore to the data directory.
/usr/share/kibana/bin/kibana-keystore create --allow-root creates=/var/lib/kibana/kibana.keystore

thanks

The keystore can only be created in data or in the config folder. However you can configure the location of the config folder wherever you want by setting an ENV variable Configure Kibana | Kibana Guide [master] | Elastic.

If you want to stop the warning, you can move your currently located keystore from the data folder into your config folder.

Cheers

thanks. let me try.