Kibana 7.4 Es 7.4 indices match issue

Centos 7,
1 es master + kibana
3 es data

I download and install es & kibana in each node by rpm way.

Then, I set up metricbeat in each node either. But when I wanna access the discovery tab in kibana, this message pop up:
No indices match pattern "apm-*" Error: No indices match pattern "apm-*" at http://kibanaIp:5601/bundles/commons.bundle.js:3:1337196

And the discovery tab couldn't load then, but I didn't set up any apm stuffs, how does it happen?

some related config as follow:

 node.master:  true   false es-master-001
 #bootstrap.memory_lock: true  nodeIp
 http.port: 9200
 transport.tcp.port: 9300
 discovery.seed_hosts: ["some ip"]
 cluster.initial_master_nodes: ["some ip"]


 server.port: 5601 "masterIp"

some hosts setting

Can you please paste your whole url when the error happens ?

Also, does the same happen when using visualize and dashboard or do they work ok ?

Can you also provide screenshot from management->index patterns.


not sure what's the "whole url", it's some private ip address like, .etc

this error alerted each time when i visit "http://masterIp:5601/app/kibana#/discover?_g=()"

but the "http://masterIp:5601/app/kibana#/visualize?_g=()", "http://masterIp:5601/app/kibana#/dashboards?_g=()" works fine for now

and so does the infrastructure, logs .etc
e.g. "http://masterIp:5601/app/infra#/infrastructure/inventory?_g=()&waffleOptions=(autoBounds:!t,boundsOverride:(max:1,min:0),customOptions:!(),groupBy:!(),metric:(type:memory),nodeType:host,view:map)&waffleTime=(autoReload:!t,time:1571040308915)"

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.