Kibana 7.3.1 "discover" tab won't load after enabling "Stack Monitoring"

I am trying to learn about ElasticSearch and Kibana. I launched both ElasticSearch 7.3.1 and Kibana 7.3.1 in Docker containers, with --net host on an Ubuntu 18.04 VM. I configured Kibana to find the ElasticSearch server on http://localhost:9200, and watched the Docker logs to ensure it started successfully.

After starting ElasticSearch and Kibana, I accessed the Kibana web console and started poking around. When I got down to the Stack Monitoring tab, I enabled monitoring. Easy enough.

However, when I tried to go back to the top Discover tab again, I am getting an error.

Error: No indices match pattern "apm-*"
at http://servername:5601/bundles/commons.bundle.js:3:2475303

How can resolve this error and access the Discover tab in Kibana again? Why did it break in the first place?

Hi @pcgeek86 thanks for trying the Elastic Stack.

That message means that Discover is looking at the apm-* index pattern which does not have any apm indexes to match to. Index Patterns are like wildcards to match 1 or more indexes.

Have you created any other indexes and then created any index patterns on the "Management / Index patterns" screen? if so just go there and select an index pattern likefilebeat-* etc and then set it to the default index pattern (The Little Star on the top right after you select the index pattern)

That should fix the issue, Or if you are actually getting to the Discover app, then just select another index pattern from the index pattern drop down on the left side.

Why? Not sure did you try to load / setup any APM data then clean it up?

Note I just created a 7.3.1 docker ES + KB from scratch, enabled monitoring and did not get the same error... that does not mean there is not an issue, just having trouble repeating

1 Like

Hi Stephen,

Thanks for the quick response. I've given it another shot this morning, and haven't been able to reproduce the behavior immediately.

The only thing I can think that I changed was to use a docker-compose.yml to spin up the ElasticSearch and Kibana containers, instead of spinning each of them up manually with docker run commands.

If I can find a consistent repro, I'll post back here. Until then, consider this a non-issue. Thanks!

Cheers,
Trevor Sullivan

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.