Kibana 7.5.1 Web Error: Private is not a function in bundles/commons.bundle.js

I just wonder if anyone here have seen following problem after installing a plugin to kibana, version 7.5.1. If I removed the plugin then everything worked fine.

After installing the plugin, kibana started fine but kibana WebUI loading encountered this error.

Version: 7.5.1
Build: 27610
Error: Private is not a function

With that error in kibana WebUI (http://:5601/), curl commands still worked. For example:

curl http://<IP address>:5601/app/features

Can you provide some more information? Are you adding your own plugin? How are you starting Kibana?


We built our own plugin back with kibana 6.8. It was working then. But, I haven't checked that for a while and now we have kibana 7.5.1. It could be some dependencies or incompatible levels of node.js and so on. There are so many dependencies in effect here.

The OS is RHEL 8.4 on ppc64le architecture.
kibana is started by using systemctl start kibana.
Please let me know if any other info is needed for debugging this problem.


Can you disable your plugin and try to start Kibana without it?

Yes, if I removed the plugin, kibana worked as usual. It's confusing though that the error pointed to commons.bundle.js. Also, kibana shouldn't be blocking access to the WebUI because of a plugin problem. Some pointers on how to debug the plugin would be appreciated. Thanks!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.