Kibana 7.6 is failing with http 413 when importing saved object file 50MB

We have elastic 7.6 and kibana 7.6 both on an EC2 instance and accessed via localhost. No components in between. I'm trying to import 50MB saved object file exported from another kibana instance . The import fails with 413.

I have set server.maxPayloadBytes: 104857600 in kibana

Should this be working or am I missing other settings. I understand elastic defaults to 100MB for http.max-content-length

Hey @Rhonda_Gregory --- There's also a separate savedObjects.maxImportPayloadBytes setting which is applied to the Saved Object Import REST API and defaults to 10MB.

I'd try increasing that and see if you have any luck.

1 Like

Thank you so much! That did the trick! We've been trying to solve this since the end of May!!! It also fixed a canvas problem we were having with large assets!

1 Like

Great! Glad to hear it worked!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.