Kibana 7.9.0 does not start when setting path.data

Hello,

I have an issue with Kibana 7.9.0.
Kibana does not start when I set the parameter path.data
I have the following error message

Configuring logger failed: { Error: EISDIR: illegal operation on a directory, read
    at Object.readSync (fs.js:498:3)
    at tryReadSync (fs.js:332:20)
    at readFileSync (fs.js:369:19)
    at Keystore.load (/xxxxx/ElasticSearch/kibana-7.9.0-linux-x86_64/src/legacy/server/keystore/keystore.js:70:45)
    at new Keystore (/xxxx/ElasticSearch/kibana-7.9.0-linux-x86_64/src/legacy/server/keystore/keystore.js:29:10)

Kibana starts if i do not customize the path.data,
no pb with kibana 7.8.1 or previous release
is it an issue on my config or a bug ?

Thanks for your helps
Brgds JL

Welcome to the forum,

it might not be related but 7.8.1 and 7.9 has bug where kibana do not start with default path /etc/kibana.

you have to do in order to fix this. add this in to kibana.service file
then systemctl daemon-reload
and start.

[root@elkdev01 ]# cat /etc/systemd/system/kibana.service |grep ExecStart
ExecStart=/usr/share/kibana/bin/kibana -c "/etc/kibana/kibana.yml"

Hi Sachin

thanks for your reply

I have not installed ELK as a unix service but from the tar file with a standard user

if you extract kibana from the tar file without updating data.path kibana starts, if you set a value on data.path kibana does not start

I am wondering if setting the data.path is still accepted, I have checked the documentation and think it is still possible.

I have found a workaround by defining a unix link between the default kibana data path and my target kibana data directory

Brgds JL

Same issue here with the same workaround

Installed kibana 7.9.0 as rpm. Without commenting path.data in the config it won't start. If that line is commented out it will start but hang up and the browser shows "kibana is not ready yet". Only after creating the link it starts working.

I also tried defining Environment variable via service drop-in:
Environment="DATA_PATH=/my/data/path/kibana"

Sadly this does not work...

I found another issue. I have a custom config path. After moving the keystore from the data path to the config path kibana also does not start