Kibana 7.9 - loops back to default space selection

I have installed elasticsearch by extracting the latest 7.9 version tar.gz method, I feel this is by the simplest method out there

then install kibana using yum install, both are version 7.9

this is the issue: https://youtu.be/tFYZz6BB3PQ

the only thing I found in the kibana log that looked anything odd was this,

{"type":"response","@timestamp":"2020-08-31T17:40:14Z","tags":[],"pid":18750,"method":"post","statusCode":403,"req":{"url":"/api/saved_objects/_bulk_get","method":"post","headers":{"host":"xxx.zzz:5601","connection":"keep-alive","content-length":"39","pragma":"no-cache","cache-control":"no-cache","kbn-version":"7.9.0","user-agent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.135 Safari/537.36","content-type":"application/json","accept":"*/*","origin":"http://xxx.zzz:5601","referer":"http://xxx.zzz:5601/spaces/space_selector","accept-encoding":"gzip, deflate","accept-language":"en-GB,en-US;q=0.9,en;q=0.8"},"remoteAddress":"10.91.120.28","userAgent":"10.91.120.28","referer":"http://xxx.zzz:5601/spaces/space_selector"},"res":{"statusCode":403,"responseTime":65,"contentLength":9},"message":"POST /api/saved_objects/_bulk_get 403 65ms - 9.0B"}

the ES logs when the above goes on:

I did try removing kibana_1 and kibana_2 indexes manually
restarted kibana
removed and re-installed kibana but I still get the same result.

OS: Centos-8.1

Interesting. Thanks for the detailed information with the video and logs.

Can you run this command against your Elasticsearch cluster and post the output here?

curl "http://localhost:9200/_security/privilege?pretty=true" -u elastic:password

Edit: make sure to run the command after starting Kibana.

Best,
-Joe

I have the same problem, with the same log entry.

I'm using the deb packages from your APT repository on Debian 10.

Here is the output of the requested command (Kibana had been running for a few minutes when I ran the command): https://pastebin.com/i4m9FwRu (output is too large for inline embedding).

Hey @Avinash_D_Silva & @AmyHipp:

Sorry you're experiencing trouble getting up and running here. Would it be possible to capture and post verbose kibana logs that show this happening? That would help me diagnose this further. I'd also be interested in getting copies of your kibana.yml and elasticsearch.yml files, but please redact any sensitive information, such as passwords.

To enable verbose logging, make the following changes your kibana.yml, and then restart Kibana:

# kibana.yml
logging.verbose: true
logging.quiet: false