Kibana asking for Enrollment Token when xpack.security.enabled: false in Elasticsearch

I have Kibana and Elasticsearch running in a kubernetes cluster, both v8.1.2

In my Elasticsearch.yml I have
xpack.security.enabled: false

This is confirmed by trying to create the enrollment token in Elasticsearch

sh-5.0$ bin/elasticsearch-create-enrollment-token -s kibana

ERROR: [xpack.security.enrollment.enabled] must be set to `true` to create an enrollment token

However, when I go to the Kibana GUI, it asks me to enter an enrollment token which I don't have and can't provide.

Looking through the docs, it suggests I don't need to do anything in Kibana to disable security but is there some configuration setting I'm missing to allow Kibana to connect without an enrollment token?

You have two options:

  1. You click on "Configure manually" right below the input box for the enrollment token and you manually add the Elasticsearch HTTP address, such as http://172.17.0.2:9200

  2. Start Kibana by passing in the ELASTICSEARCH_HOSTS env variable, i,e, -e "ELASTICSEARCH_HOSTS=http://es01-test:9200"

In theory, you can always pass -e "INTERACTIVESETUP_ENABLED=false" to disable the interactive setup mode but in this case, if you don't configure anything else, kibana will try to connect to localhost to find Elasticsearch on 9200. When in k8s or docker, that localhost is the container where kibana runs so this will fail. It would work if both kibana and Elasticsearch run from archives on the same host.

HTH

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.