Kibana automatically adjusting time

I have field named datetime and the type is date. Here's my mapping

{ "mappings" : { "properties" : { "datetime" : { "type" : "date", "format": "dd-MM-yyyy HH:mm:ss.SSS"} } } }

I'm in GMT+7, and Kibana always adds 7 hours to datetime field. For example, in elasticsearch the value of datetime is 21-08-2019 09:25:11.371. Kibana shows 21-08-2019 16:25:11.371 for this data.

I don't want Kibana to add 7 hours to datetime. How can I stop this?

Hi @Budi_H

The possible cause of this could be the format stored in ES: If you are sending your date already formatted in your current timezone but you don't specify the timezone in the value passed to ES, ES will think that this value is in UTC https://www.elastic.co/guide/en/elasticsearch/reference/current/date.html converting it to something like 2019-08-21T09:25:11.371Z
If Kibana is configured with Browser timezone (GMT+7), then that value will be formatted as +7 hours.
Please check if the value sent to ES are in UTC. If not you should configure your ingestion to take care of the timezone, or you can configure your mapping with a different timezone.

Please check also the value configured in the Kibana Advanced Settings under dateFormat:tz.

Setting dateFormat:tzin Kibana to UTC solved my issues. Thanks

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.