Kibana is changing my dates to a different timezone

I'm on elasticsearch + kibana 6.0.0-rc2. I have a date field defined in my index like this:

"timestamp" : { "type" : "date", "format" : "date_hour_minute_second_fraction" },

and an example of my data in elasticsearch looks like this:

"timestamp": "2017-11-01T09:49:23.593",

But in the kibana discovery the date is being changed by 4 hours and looks like this:

timestamp:November 1st 2017, 05:49:23.593

I'm in the US Eastern timezone and my machine time is set correctly. I've tried changing the Kibana setting dateFormat:tz to US/Eastern to no avail.


All timestamps in Elasticsearch are assumed/required to be in UTC. Are your events adhering to this?

Yes that was the problem. I was not inserting UTC dates in to the elasticsearch index. I'm still not sure though why kibana would make the decision to adjust the date as opposed to just returning what is in the index.

Anyway, thanks for the quick answer.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.