Kibana TimeZone doesn't change


(Mikhael) #1

Hi everybody,

Before everything, I´m sorry for my bad english. I´ll try to be clear and brief.

I´ve already tried changing my timezone, but I didn't succeed.

I changed the timezone on "Advanced Settings", "dateFormat:tz" like you can see below.

This is my computer local date, right now

image

But in Kibana when I insert the date "22/08/2017 09:00:00", it´s showing me

image

What am I forgetting?

Thank you for your attention


(MH) #2

Hello Mikhael,

I think it's specific of your date field in your document. Can you paste the JSON view of this doc ?
But to be sure : when you "insert the date", you mean that you choose a time range with the Time-picker (image) ?

image

Except error, Elasticsearch works only with UTC time and Kibana manage itself the documents date you watch to adapt with your timezone.


(Mikhael) #3

Hello MH,

I expressed myself very badly, sorry.

When I said "insert the date" I was saying when I add a document into ElasticSearch how you can see below.

PUT date-test/person/1
{
"date": "22/08/2017 09:00:00"
}

And this my mapping.

PUT date-test
{
"mappings": {
"person": {
"_all": { "enabled": false },
"properties": {
"date": {"type": "date", "format": "dd/MM/yyyy HH:mm:ss"}
}
}
}
}

Thank you for replying


(MH) #4

Hi,

No problem, not the only one :slight_smile:

With the fact that elasticsearch works and index doc with UTC timezone, you have to specify in your logstash pipeline, in date plugin, the timezone of your "date" field ; here seem Brazil BRT (UTC +3, no DST).
Try to specify the timezone option.


(Mikhael) #5

Hi MH,

I understand what you said. But I just doing a prototype, for this reason I've tried add my document by Sense plugin or Kibana Dev Tools.

In the final version I will use Java API to loading my data.

Is the problem in my Kibana configuration? I say it because, take a look in my data when I use Kibana Dev Tools.

It's the way that I would expect, in Discover tab.

Thank you for replying


(Mikhael) #6

Hi everybody,

I found a solution. But , I'm not sure If it's the best alternative to me.

What did I do?

I changed the dateFormat:tz in the Kibana to UTC. After did it, my Kibana has worked well.

Thanks for all attention


(Mikhael) #7

Hi again everybody,

I'm sorry for posting again here, but I need to help again. I thought that I found a solution, but I was wrong.

The problem is not solved. I will print what I'm doing step by step.

FIrst, it is my mapping and how I add my document

This is Kibana view,

When I change to last 15 minutes

TimeZone:

And the time in my computer

image

What am I forgetting?

And I'm sorry for my bad english again.

Thank you


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.