Kibana.bat errors on Windows 10


(Paul Brown) #1

HI,

I'm new to all this Elastic Search and Kibana technology but have started to look at it. I've downloaded and installed ElasticSearch-2.0.0 and that's working fine.

To go with this I've downloaded Kibana-4.2.0-windows but when I try to run Kibana.bat I get the error message

\nodejs\node.exe was unexpected at this time.

and nothing runs.

Any help would be much aprreciated


#2

Hi Paul,

I've been trying out the new Elasticsearch 2.0 stuff on windows as well, and ran into this error. I don't know what the source of the problem is - but I know in my case I already had nodejs installed. Wondering if it is a path conflict or something...

Anyway, I was able to bypass /bin/kibana.bat and run node directly against what the .bat file sets up. Basically it boils down to:

path_to_nodejs.exe /path/to/kibana/src/cli/index.js

so I ran that with my system instance of node like this:

cd kibana-4.2.0-windows\src\cli
node index.js

and it started just fine!


(Paul Brown) #3

Thanks for that, that's exactly what I had ended up doing myself. Would be nice to know what the underlying cause is!


(Ron West) #4

I figured out how to resolve . Even if you have node already installed, you have to add the node directory to your windows path.

on my machine I added:
C:\Elastic\kibana\node
to the path and everything works now.


#5

There is a problem with spaces in the path.

Just add quotes around %SYS_NODE% where you set the NODE variable on the line 14 of kibana.bat :

old:
set NODE=%SYS_NODE%
new:
set NODE="%SYS_NODE%"

After that fix, it works on my WIndows 10 machine.


(Joe Fleming) #6

Thanks for the fix. We're planning to remove the whole system node fallback stuff from the build in the near future as well, so this code won't even be there anymore.

See https://github.com/elastic/kibana/issues/5673


(system) #7