Marvel installation nodejs error?

monitoring

#1

Newbie question.

I have ES 2.1.0 installed. I installed kibana 4.3.0. The marvel 2.1.0 plugin is installed in ES.

The marvel installation instructions next said to install in kibana via: bin/kibana plugin --install elasticsearch/marvel/latest

when i try that i get this error: \nodejs\node.exe was unexpected at this time

I am not sure what this is telling me. I see nothing about nodejs in the installation instructions.

Thanks in advance for any help.


(Steve Kearns) #2

This looks like it might be a problem with Kibana's ability to install plugins on your system, rather than a problem with Marvel itself.

To confirm, can you try installing Sense, which an interactive ES query builder/editor, into Kibana like this:

bin/kibana plugin --install elastic/sense

Please let us know if that is successful. Also, what OS and Java versions are you running?


#3

Yep, you are right. Same problem. I am running Windows 7 with jre 8.

Looking at the kibana bat file… NODE is set to ./kibana-4.3.0/node/node.exe. Which exists. So I am not sure why - If Not Exist "%NODE%" – is failing.

Thanks.


(Steve Kearns) #4

I'm not a Kibana plugin ninja, but Is there anything strange going on with file permissions in this directory?

Are you running this in a console with cygwin, powershell, or cmd.exe?

I just tried this on my windows 10 machine from the cmd.exe console, with Java version "1.8.0_66" and it worked fine, though I had to use the backslash between bin and kibana:

bin\kibana plugin --install elastic/sense


#5

i am truly confused. i found a post for a windows batch file issue that looked similar to the logic in the kibana.bat file indicating the error message was unexpected at this time means there was an issue parsing the open and closing parens in the IF statement. So I rewrote kibana.bat to be:

If Exist "%NODE%" goto :run
IF Exist "%SYS_NODE%" goto :usesys
Echo unable to find usable node.js executable.
Exit /B 1
:usesys
set NODE=%SYS_NODE%
:run
TITLE Kibana Server
"%NODE%" "%DIR%\src\cli" %*

I think I got further, not sure. but i do have a different error:
c:\Executables\kibana-4.3.0>bin\kibana plugin --install elasticsearch/marvel/latest
c:\Executables\kibana-4.3.0\src\utils\packageJson.js:20
throw new Error('unable to find package.json');
^
Error: unable to find package.json
at Object. (c:\Executables\kibana-4.3.0\src\utils\packageJson.js:20:11)
at Module._compile (module.js:460:26)
at Module._extensions..js (module.js:478:10)
at Object.require.extensions.(anonymous function) [as .js]
(c:\Executables\kibana-4.3.0\node_modules\babel-core\lib\api\register\node.js:214:7)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at requireModule (c:\Executables\kibana-4.3.0\node_modules\requirefrom\index.js:24:10)
at Object. (c:\Executables\kibana-4.3.0\src\cli\cli.js:6:11)

I looked at packageJson.js. It looks like that error comes from not being able to run from the right directory level. I feel like I am doing something fundamentally wrong, but its escaping me. Why does it work for you and not me?
I open a command shell at the top level kibana folder (where I unzipped) and run bin/kibana...


(Steve Kearns) #6

In nearly all cases, editing the kibana.bat is a bad idea :slight_smile:

If it works for me but not you, it's likely to be something environmental on your side.
What command shell are you using? cmd.exe, cygwin, powershell? I'm using cmd.exe.
Which Kibana file did you download - the zip or the tar.gz? (possible that if it was tar.gz, there are line-ending mismatches?)
Did you check folder/flle permissions? Do you have anything Node.js related on your path?


#7

It was one time experiment to just see what would happen if I got past the bat file IF. It must be environmental.

So when things are environmental, the tough get going. :>)

I restarted the entire process by downloading a new zip file. (I did have zip previously)

When I ran from the new download, it worked!

When will I learn? When errors make no sense, start over completely.

Thanks.


(Steve Kearns) #8

I'm glad to hear you're up and running! :smiley:


(system) #9