Installing Marvel 2.1 issue

monitoring

(TW) #1

I'm following the Intro video for ES and downloaded ES 2.1.0. I'm now trying to install Marvel 2.1 and following the instructions in the table at https://www.elastic.co/downloads/marvel
Step 1 worked, but when I run the command for Step 2 as:
bin/kibana plugin --install elasticsearch/marvel/latest
I get the error: bin/kibana: No such file or directory

I'm running the command from the root of the ES directory. Do I need to install Kibana before Marvel? If yes, then where should the Kibana directory be located WRT to the ES directory?


(Vincent Tran) #2

bin/kibana plugin --install elasticsearch/marvel/latest is meant to be executed on the Kibana node (just provide the full path). And yes, you do need to install Kibana.

Kibana is independent of ES. You can place it wherever you like.


(Mark Walkom) #3

I didn't realise you had your own thread. See my response here Where to get marvel 1.3

You cannot use Marvel 1.3 with ES 2.X.


(TW) #4

Yep, two different issues - download and then install problems.


(Mark Walkom) #5

Ahh ok. Then what @vtst2412 mentioned if your problem.


(TW) #6

Yep, it's up and running now. Thanks so much for the help @warkolm and @vtst2412!


(system) #7