Marvel with Elastic Search and Kibana

monitoring

(Arjun Gulyani) #1

I started with Marvel Installation Process Marvel Installation and then Installed the License, Marvel Agent and Started the ElasticSearch as Shown by Steps by 1 a,b,c and when I move to Step 2

bin/kibana plugin --install elasticsearch/marvel/2.3.3

it says

C:\Users\Arjun\kibana-4.5.1\bin>.\kibana plugin --install elasticsearch/marvel/2.3.3
Installing marvel
Attempting to transfer from https://download.elastic.co/elasticsearch/marvel/marvel-2.3.3.tar.gz
Transferring 1597693 bytes....................
Transfer complete
Extracting plugin archive
Extraction complete
Plugin installation was unsuccessful due to error "EPERM: operation not permitted, rename 'C:\Users\Arjun\kibana 4.5.1\installedPlugins\.plugin.installing' -> '
C:\Users\Arjun\kibana-4.5.1\installedPlugins\marvel'"

Using Windows 7, what's wrong ?


(Steve Kearns) #3

Hi Arjun,

It looks like there is a permissions problem with part of the installation. I know that some Windows versions set rather odd permissions in the home directory, so can you try creating a new folder at the top level, and ensure that your user has privileges to read/write/modify that directory, and place the Kibana installation there, then re-run the plugin installation?

Thanks,
Steve


(Arjun Gulyani) #4

Tried that again by Disabling the Antivirus Software and then it worked wonders. Will Try Your Way tooo. Thanks


(system) #5