Kibana Can Not Connect to elastic search plugin

hello there,

actually i try to use sense plugin. in order to do that, i need to install kibana first.
so i install it, and try to connecting it with elastic search. when i run this command :
cd kibana/bin/kibana.bat

everything running well. untill i go to http://localhost:5601/app/sense

like in the image below, kibana can not connect to elastic. they said that service unavailable.

i check the kibana server, and got this :

i did check localhost:9200, and its work perfectly fine.

i try using postman, but got nothing bro.

im so confused.
please help me.

many thanks in advanced

Are you sure you are using the right versions? If I look at the output from localhost:9200 you are running the alpha version of elasticsearch 5? Are you also using the alpha version of Kibana 5? In the alpha version there is not longer a need for sense. The alpha version of Kibana comes with Console which is the new name for sense. It looks like you are running Kibana 4 against Elastic 5 and that is supported. Actually when I try to boot Kibana 4.5.1 against elastic alpha it does not even start.

In short, what versions of elastic and Kibana are you running?

yeah you right.

kibana 4.5.1
elastic search 5.0.0 alpha 3

so what shoul i do?
i dont know what version should i use in order to running kibana and elastic together.

I would go for elastic 2.3.3 and Kibana 4.5.1

hello @jettro , i already installed elastic 2.3.3 and kibana 4.5.1
and its like it will be success integrating sense plugin in kibana and elastic.


kibana loading too long.

Strange, I do this regularly and it works without problems for me. Did you check the elasticsearch and the kibana logs? Anything in there? Especially in the Kibana log.

yes i agree its strange bro.
i tried install kibana plugin, sense.
when i try to access sense, it work perfectly.

where can i check the logs from kibana and elastic?

If you start Kibana from a command prompt you can see the logs there.

oh i got it.
in elastic when something goes wrong, i got message written in my cmd.
but sadly in kibana, i got nothing.