Kibana cannot be accessed on different port other than 5601


(vamshi) #1

I cannot access Kibana on different port other than 5601. I changed the server.port property in Kibana.yml file to several different unused ports. But I cannot access it from those ports. I can only access it on port 5601.


(kulkarni) #2

hmm, thats all is needed to load it on a different port - To change the host or port number, or connect to Elasticsearch running on a different machine, you’ll need to update your kibana.yml file.
Did you restart your service , post the changes to make the changes apply? Any logs to support or any kind of screenshot you could provide?

Cheers
Rshmi


(vamshi) #3

Yes, I did restart both elasticsearch and kibana services. My log files are full of logs as of now and it is taking a while to load them. Can I delete the logs and regenerate them after restarting the service?


(kulkarni) #4

Yea, if you don't care about the old logs, you can always restart the service and logs will start collecting as well.

Cheers
Rashmi


(vamshi) #5

I've cleared all logs. Now after I change the server.port property to 5602 and restarted the service, I see following logs in kibana.log file:

{"type":"log","@timestamp":"2018-10-11T14:53:00Z","tags":["listening","info"],"pid":6884,"message":"Server running at http://10.*.*.*:5602"}
{"type":"log","@timestamp":"2018-10-11T14:53:00Z","tags":["status","ui settings","info"],"pid":6884,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}

When I access the kibana page on 5602 poet, it says: " This site can’t be reached

10...* took too long to respond.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.