Kibana cannot startup - always tried to migrate

Hello team,
I have issue with Kibana that cannot start up .
before it was deployed into Openshift3 , Kibana version showed as 7.9.3 - Elasticsearch is 7.9.2
now, I tried to shutdown old cluster instance on Openshift3 and deploy it into Openshift4 , Kibana version used from binary was 7.9.2 , and Kibana always want to migrate .kibana_1 into .kibana_2 , and then it throw this error :

FATAL Error: Document "9aaf9a50-qaa2-11eb-a2c7-12346f90a21" has property "visualization" which belongs to a more recent version of Kibana [7.9.3]. The last known version is [7.8.0]

and then it restart and throw this error after restarting :
{"type":"log","@timestamp":"2022-10-10T09:34:45Z","tags":["warning","savedobjects-service"],"pid":1,"message":"Unable to connect to Elasticsearch. Error: [resource_already_exists_exception] index [.kibana_2/xSSxqsV7ThetGKVwbu0RRt] already exists, with { index_uuid="xSSxqsV7ThetGKVwbu0RRt" & index=".kibana_2" }"}
{"type":"log","@timestamp":"2022-10-10T09:34:45Z","tags":["warning","savedobjects-service"],"pid":1,"message":"Another Kibana instance appears to be migrating the index. Waiting for that migration to complete. If no other Kibana instance is attempting migrations, you can get past this message by deleting index .kibana_2 and restarting Kibana."}

do you have any idea how to solve this without losing all saved objects ?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.