Kibana start problem issue

Getting this error when Kibana is started and it won't start -

Elasticsearch -OSS and Kibana - OSS version 7.2

FATAL [index_not_found_exception] no such index [.kibana], with { resource.type="index_or_alias" &".kibana" & index_uuid="na" & index=".kibana" } :: {"path":"/.kibana/_count","query":{},"body":"{"query":{"bool":{"should":[{"bool":{"must":[{"exists":{"field":"index-pattern"}},{"bool":{"must_not":{"term":{"migrationVersion.index-pattern":"6.5.0"}}}}]}},{"bool":{"must":[{"exists":{"field":"visualization"}},{"bool":{"must_not":{"term":{"migrationVersion.visualization":"7.2.0"}}}}]}},{"bool":{"must":[{"exists":{"field":"dashboard"}},{"bool":{"must_not":{"term":{"migrationVersion.dashboard":"7.0.0"}}}}]}},{"bool":{"must":[{"exists":{"field":"search"}},{"bool":{"must_not":{"term":{"":"7.0.0"}}}}]}}]}}}","statusCode":404,"response":"{"error":{"root_cause":[{"type":"index_not_found_exception","reason":"no such index [.kibana]","resource.type":"index_or_alias","":".kibana","index_uuid":"na","index":".kibana"}],"type":"index_not_found_exception","reason":"no such index [.kibana]","resource.type":"index_or_alias","":".kibana","index_uuid":"na","index":".kibana"},"status":404}"}

Also, I have been seeing the below error sometimes -

{"type":"log","@timestamp":"2019-08-28T14:33:38Z","tags":["warning","migrations"],"pid":1442,"message":"Another Kibana instance appears to be migrating the index. Waiting for that migration to complete. If no other Kibana instance is attempting migrations, you can get past this message by deleting index .kibana_1 and restarting Kibana."}

Is this a new installation or existing? Which .kibana* indexes do you have in elasticsearch?

new installation

elastic shows .kibana_1 but I've installed elastic + kibana both 7.2.0

If you don't care about any of the Kibana-related information already stored, you can DELETE .kibana_1 like the error message says. Otherwise, you can create an index alias for .kibana -> .kibana_1 and that should fix it:

this worked however , the issue was elastic nodes were marked as masters only. Changed them to master + data and kibana worked !

@wylie , now I ran into this problem - Saved object is missing Could not locate that visualization

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.