Kibana - Canvas


(Thorsten Nickel) #1

Dear Canvas Team,

did a quick install on my 6.0.1 Kibana Instance and played around with it a bit.
Some points I got so far are:

  • Kinda breaking : If I like to incorporate TimeLion as a datasource, it bails out with the error message that a self-signed certificate has been encountered. ES in itself runs with x-pack security turned on ... perhaps make this configurable ?

  • A bit irritating : When editing the source of the different pipeline elements, hitting the backspace key for editing purposes took me instead to the browser function of getting back in page history...

  • Weird in a way : When using standard ES source for data to be displayed, it seems that pure numerical data won't be picked up correctly. Defining @timestamp instead does, i.e. I can put that into the x-axis for display.

Other than that I have to say, wonderful work with canvas, keep it going!

Best wishes,
Thorsten


(Rashid Khan) #2

Thanks for the feedback, we'll check it out!

I hadn't seen the self signed cert thing, but I can totally see how it happens. Usually timelion requests are made from the browser, eg, in the Timelion app, so you've already accepted the cert. In Canvas they're made from the backend and the system cert store doesn't have the self sign cert.

Backspace, autocomplete is a bit wonky right now, we're working on it :slight_smile:

esdocs, interesting that numeric types aren't picked up right. I'll poke at that. If you want to hack it until I figure it out you can use alterColumn to cast the column to a number:

esdocs fields="notAnumber" | alterColumn column=notAnumber type=number

(Lukas Olson) #3

Which browser/OS are you using?


(Thorsten Nickel) #4

Hi,

I'm running Firefox 52.5.0 (32-Bit) on the ESR Channel, so that should be quite stable.
System is Win7 Enterprise SP1.

I tried the solution Rashid suggested, but I still get an error that the column could not be found.
So I add 2 Screenies for this.

First one shows, in adding columns through the Elasticsearch datasource, I get a popup showing the (number) field being there.

Second one show the piped query with the error message on it. Hope this helps to boil down the error...

Best wishes,
Thorsten


#5

Running into an issue with Canvas on kibana 6.1 (RHEL 6.6). The installation went well with instructions provided but when clicking on canvas all I get is a blank screen. Below is the output from Chrome developer tool and I didn't notice anything useful in Kibana logs (same issue with ie). Also completed the installation on my windows 10 device and had to update kibana-plugin.bat with "NODE_OPTIONS="--max-old-space-size=4096" instead of calling it in command line.

Thank!

Kudos to everyone working on this project! To echo Thorsten, keep it going...

commons.bundle.js?v=16337:94 TypeError: (0 , _lodash.uniqBy) is not a function
at new (canvas.bundle.js?v=16337:103)
at Object.instantiate (commons.bundle.js?v=16337:94)
at Object. (commons.bundle.js?v=16337:94)
at Object.invoke (commons.bundle.js?v=16337:94)
at Object.$get (commons.bundle.js?v=16337:94)
at Object.invoke (commons.bundle.js?v=16337:94)
at commons.bundle.js?v=16337:94
at getService (commons.bundle.js?v=16337:94)
at injectionArgs (commons.bundle.js?v=16337:94)
at Object.invoke (commons.bundle.js?v=16337:94)
at commons.bundle.js?v=16337:94
at forEach (commons.bundle.js?v=16337:94)
at Object. (commons.bundle.js?v=16337:94)
at Object.invoke (commons.bundle.js?v=16337:94)
at Object.$get (commons.bundle.js?v=16337:94)
at Object.invoke (commons.bundle.js?v=16337:94)

commons.bundle.js?v=16337:66 Promise: Detected an unhandled Promise rejection.
TypeError: _lodash2.default.uniqBy is not a function
canvas.bundle.js?v=16337:103 Uncaught (in promise) TypeError: _lodash2.default.uniqBy is not a function
at canvas.bundle.js?v=16337:103
at


(Rashid Khan) #6

We're working on the uniqBy thing. We think it has to do with some webpack changes. Should have a new build out soon!


(Shreyas Karnik) #7

I ran into the same I guess: Canvas App Blank


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.